Performance - PC FPS Performance drop since update 5 (1723963)

Since update 5, my 3080Ti based PC FPS has halved with reasonably high settings from over 70 to 25 to 30. The graphics also grainier. I also noticed when turning the steering wheel, the parts of the dash behind the steering wheel go very grainy, and take 3 seconds to rectify.

Bug Info: (Happening on several tracks I tested)
Platform: (Windows PC)
Edition: (Game Pass)
PC GPU: (Gigabyte 3080Ti / NVIDIA Drivers 551.52)
Settings: (PC graphics or visual setting) Mostly high/uptra, No DLSS

Content Update: Was this happening prior to the most recent content update or did it start after the update? No FPS was more than double

Mine went from 80fps to 40fps and a lot of stuttering. I updated Windows, drivers, etc. Now it crashes on launch. I am tired of FM’s issues.

2 Likes

Same for me. New update is a mess.

1 Like

Stuttering and blurred visuals since update 5 here too although FPS count is slightly higher than before update.

LG CX 120hz TV

Windows 11, latest update

RTX3090, latest driver

Ryzen 7 5800X3D

Game settings 4k, max everything, unlocked FPS, noticed increased vram usage.

Setting to 60 vsynch fixes stuttering but not blurring. Looks like 1080p!

1 Like

Stutter count in the benchmark has gone from 0 to 248

Memory Leak i think, we need to restart the game to fix.

2 Likes

Game stuck at 55fps at all track, single and multiplayer after new update. before update in game fps around 80fps to 100fps. please help.

5800x
6900xt
32gb ram

FPS Drops from Hell. Never happend before Updated 5.0 :unamused:

i just found out that the fps will go 60fps max for multiplayer because of “fairplay” rule set by forza.

2 Likes

Same here. However on multiplayer i’m not experiencing this issue, but when playing career mode, after one race, my fps fomr 80 dropping to 20. When restart the game it’s fine for one race. Also noticed, more loading times, and when try to change the fuel, also more bugs, and more loading times.
GPU: RTX4070 TI
CPU: Ryzen 5 56000x
RAM: 32GB

2 Likes

Yes, it improved in single player mode, I saw a pretty good increase in FPS. But there is a bug that when I enter multiplayer mode I have a sharp drop in FPS and I discovered that it happens when in multiplayer mode I have the frames option unlocked. If I limit it to 60 fps when playing multiplayer it works perfectly.

If it happens only in multiplayer you should go to options and limit the fps to 60

Career mode unlocks FPS and multiplayer limits it to 60

Like everyone else, after playing the game for a while after update 5, the FPS plummeted again.

Since update 5, my FPS has increased to around 90 ~ 100 on average when single playing in my environment (this has improved since before update 4), but after playing the game for a while and starting the next race after completing the first race in the series in Career mode, my FPS during the race has drastically decreased to around 30 ~ 40 and will not go away until I restart the game.

I recorded the video from the start of the game to send it to support, but I didn’t experience any symptoms after playing the game for an hour.
Thinking back to what I did when it happened, I remembered that I had the car upgrade/tune screen open between races.

This has been happening since before update 4, and I’ve contacted support about it, but it was fixed by changing the settings in the game based on information from support, but now it’s happening with those settings, so it seems to be a new cause.

Reference: https://support.forzamotorsport.net/hc/en-us/requests/549396

DLSS still doesn’t work (in fact, it even drops the FPS a bit when enabled), so come on.

Maybe you ppl should try to deactivate V-Sync in the game, set it to unlocked instead and use nvidia control panel or AMD adrenaline or whatever it’s called and activate V-Sync there. If that doesn’t help try to activate Triple Buffering. If that doesn’t help lower the graphic settings. I would recommend the Digital Foundry Settings. They work fine for me, i don’t use Raytracing and don’t have the FPS drops at all.
I use R9 5950x / RTX 3080 / 32GB RAM / GEN4 NVMe with active DirectStorage.

The whole video is useful information.

Current Dynamic Render Quality: Custom
Dynamic optimization: Custom
Fullscreen: On
Show framerate: On
NVIDIA DLSS: Off
AMD FSR 2.0: Off
Performance target: Unlocked
Resolution scale: 100%
Anistropic filtering: 16x
Raytracing quality: Off
RTAO quality: Low
Shadow quality: High
Cubemap reflection quality: Low
Car model quality: High
Car livery quality: High
Windshield reflection quality: High
Mirror quality: Medium
Track texture quality: High
Particle effects quality: Medium
Motion blur quality: Off
Lens flare quality: Off

These are basicly the Digital Foundry Settings.

Make sure to have V-Sync and G-Sync/Freesync active in the GPU driver settings, and somehow limit the FPS to 75 or 60. And make sure to RESTART the game after changing ANYTHING in the graphical settings.

2 Likes

Exactly my problem. Please fix!

As of update 5 if u play with more 100hz monitor, your multiplayer fps will be halved, and if u have 165hz monitor your fps will be locked to 165/3=55 it’s just to limit your fps to 60 :joy:

3 Likes

In order to improve the fps issues on pc use the following settings------------->

Car livery details: use high (ultra settings destroy Performance on low VRAM GPUs completely) or lower settings
Ray tracing: turn it off completely
Track texture details: medium settings

Dynamic render quality: high for 1440p, medium for 1080p, and ultra for 4k
Performance target: test all options and find out what works best for you - for me setting it to unlocked seems to work best

All other settings have just a minor impact on FPS. Don’t deleted any game files and don’t force any settings via GPU drivers - it just doesn’t work.

1 Like

Exactly!

Still having this issue while playing featured mp on 170Hz monitor.

I am using this workaround:

  1. Set your refresh rate to 60Hz on windows advanced display settings BEFORE opening the game;
  2. Start the game and join any featured mp room;
  3. While in-game and in the practice session, alt+tab, go to windows advanced display settings and change back to any refresh rate you want, in my case 170Hz.

Hope it helps guys! :heart:

1 Like

U can change to 100hz to get 100 fps in multi. And u don’t have to join multiplayer, it’s enough if u change once main menu loads on.

And if available u can set 72/75 Hz before lunching game

W8 for menu to load and set monitor to 90/100hz and u can play with 90/100fps max in multiplayer while keeping 72/75 fps in single player

Tho u need to do this every time u restart game.