What the hell is happening to my account?

Crap I forgot I got the game in my mother language: Italian, but the game is telling me that my profile is no longer avaible. Any one else got this problem? Any solution?

What console do you play on?

1 Like

I play on pc and got the game on microsoft store

2 Likes

It appears to be a bug in the PC client introduced by the Feb. 6 Hotfix.

It is being discussed in the Hotfix thread:

https://forums.forza.net/t/feb-6-hotfix-version-634-818-0/670312/17

1 Like

I think the best thing to do is watch some tutorials on how to fix it. I now how to fix this problem on Xbox, but I don’t know how to fix it on PC. Sorry I can’t help you directly.

I don’t think this can be fixed by the end user. PGG is going to need to fix their code. The game will load and run on Xbox Cloud Gaming, and probably on a console. It is the PC client that is broken.

1 Like

@Methariorn

This was a common problem in FH4 and was the reason why I used to keep a regular backup of my PC save files/folders so that I could easily restore it when it went bad but FH5 introduced a piece of code that automatically corrupts restored save files/folders which annoyed me.

The official way is to contact support and hope they are feeling uncharacteristically supportive but they have always been useless to me so I find my own ways of doing things.

The only way I’ve found to restore a save if sync doesn’t work is to rename your save folder and get it to re-sync with the cloud. This is a bit of a dirty hack that tricks Windows into thinking its a new game install with no local save. This may take some time to sync the full save.

I would always try playing the game on another platform and having a more recent save than the local PC version then trying a normal sync before renaming the local saves because this method does come with some considerations and I advise you to do this with care.

The point about having a more recent cloud save is very very important

1 - You need to have another platform to make a more recent save i.e. Console or Cloud
2 - Do not delete your renamed save files/folders until a new one has successfully downloaded and been tested because there is always a chance of undoing the rename if things go wrong

The local save folder is likely stored on the C drive at

/Users/Username/AppData/Local/Packages/Microsoft.624F8B84B80_8wekyb3d8bbwe/SystemAppData/WGS

You need to have “hidden items” enabled to view the AppData folder - its in the view menu in explorer

Rename the wgs folder with -old on the end (i.e. wgs-old) so its easy to tell the difference and revert if needed. It may be worth rebooting the computer after doing this.

Next try to load the game and see if the sync dialogue is displayed - if it is then let it run but it may take some time. If you still get the error then remove the -old from the folder name and it may be time to contact support

This would be my method around this problem but I am quite experienced with messing around with computers and game file systems

1 Like

I have already tried the last-known-good game save method on an air-gapped system that could not synchronize bad data from the cloud. The patched version of the game still could not load it. The game does load and run on xCloud with the current cloud save. There does not seem to be any problems with the user profile or game save, just the PC client can’t load it since applying the Feb. 6 hotfix.

1 Like

3 Likes

I play on MS Store PC and Cloud and I’ve not seen this issue on either platform so I’m working from previous experience with the error but like many Forza bugs, it affects limited number of accounts and this time I’ve been lucky

If re-syncing or even re-installing the game on the PC doesn’t work then it might be worth sticking to alt platforms until its fixed but I suspect the problem is the local save because the cloud data seems sound and an Air-Gapped system will only load local data by virtue of its nature

Restoring local data to local data is known to corrupt the save files, I’ve seen restore points cook the saves before - I suspect its due to save swapping protections, but taking the local save out of the mix and forcing a full sync from the cloud has been my solution since FH4 and FM7 and has been needed a few times in FH5

The updates do need to be quality tested before release but some of the policy decisions in the games functionality and the fact Windows is just an unreliable OS so mean that you cannot always trust local “known-good” versions

1 Like

thats interesting because normally for me, game services stops the game loading at all but I wouldn’t be shocked if game services had a hand in this too because it’s such a buggy piece of software

1 Like

I have an Xbox One and the issue is fixed when I restart my console.

1 Like

Okay, cool! I’ll give that a try. Thanks.

2 Likes

If you’re on PC, always make sure you’re logged in to the xbox app, and check the game bar (windows key + g) to double check that you are before you start playing FH5 (and FH4).

It’s a pity that the message doesn’t tell players this rather than give some meaningless, opaque error code.

I note this seems to have been happening quite a bit of late.

1 Like

So I just need to wait for Play Ground to release a fix? Nice :slight_smile: considering how fast they are to address the mess they do.

Here’s how I fixed it:

Sign out of Xbox app on PC
Go to Settings/installed apps, find the Gaming Services. Under Advanced options Uninstall the app
Open Xbox app again, this will re-install Gaming Services
Open FH5, and select your account. It will then work.
It’s annoying though as every time you check for Store app updates Gaming Services will re-install again and the problem comes back.

1 Like

THANK YOU! This worked on PC/Xbox!

2 Likes

It’s a workaround but it’s annoying as you have to do this EVERY TIME you check for app updates on the Windows Store.
I’ve received a response from my ticket, awaiting further updates.

1 Like

I’ve had this update from Forza Support.
I’m not willing to completely reset my Forza game right now, but this is what they suggested (see pic)

I actually tried the third part of this suggestion - Gaming Services wouldn’t even re-install from that link.
Screenshot 2024-02-14 152922

1 Like

Well now even my fix won’t work so can’t run the game at all.
Xbox app had an update earlier.

1 Like