MS Gaming Services updates break the game

I posted here yesterday about me getting an Invalid Profile error when starting the game, for some reason that post has disappeared like it never existed.

Anyway I did solve the problem. Gaming Services had an update yesterday, which gave me the error with the game (shown in pic). No other games were affected.
I was able to fix it by signing out of Xbox PC app, uninstalling Gaming Services and then re-opening the Xbox app, which re-installed Gaming Services. After signing in again the game worked fine.

Another update to Gaming Service today and the problem came back. Again fixed the same way.

I’ve only been getting this problem since a recent FH5 update.

Same just happened to my son’s profile. It was fine yesterday, and gave the error above this morning.

It looked like a corrupted game save, but i verified that wasn’t the case by loading up on one of pur Xbox consoles. It synced up just fine, so i knew his save was fine.

That was unfortunately after i had reinstalled the game.

After the reinstall, i then had problems syncing his data. Mine was fine. My son’s data just wouldn’t sync to the pc.

Once that was sorted his game was giving the profile error again.

That’s when in found this post. My gaming service was updated yesterday, so I guess caused the same issue.

I followed the steps here, and all working :slightly_smiling_face:

I hope they sort the issue, as it sounds like it might re-occur with an update to gaming services

2 Likes

Glad my solution worked for you. The issue is either with GS updates or more likely the most recent FH5 update as all other games are fine with the same profile.

I was in a state of panic that I’d lost over two years of gameplay

2 Likes

Gaming Services updates itself every time it’s re-installed through the Xbox app!
So we have to go through this whole ball-ache process every time.
It must be a Forza issue as other games work.
Simply resetting the GS app doesn’t fix it either, full re-install needed every time.
I’ve now raised a ticket with Forza support

1 Like

Not sure how to uninstall it. The “uninstall” button is greyed out in the Apps/Installed Apps list. Am I looking in the wrong place?
image

Im currently unable to open the Xbox app at all. I am not logged out of my account but the app itself is stuck at the Xbox logo. I am opening the game just fine, no errors. Tried uninstalling and installing again and it didn’t work. Seems like this very recent Xbox update broke something. Don’t think it’s forza’s fault.

You need to go to Settinge > installed apps, find Gaming service in the list, select Advanced and then uninstall from there. It’s a total pain in the balls.

Every time you check for updates on the MS Store Gaming Services installs again anyway and the problem starts again

Yeah. That’s where my screen shot came from. It’s still greyed out.

Weird, I have the option to uninstall

1 Like

Try repairing Gaming Services in Apps & Features - Advanced options - Repair. This helped me with the Xbox app not launching at all. Might help with your issue too.

You can disable automatic updates in the Microsoft Store - Click on the little circle icon on top that has your initials - Settings - App Updates option is right on top. And that’s in case if Gaming Services updates again and breakes something as BlueMonday19 said.

Even if Store auto updates are disabled, clicking ‘get updates’ will still install Gaming Services again!
It’s a total clusterf*ck

Repair of the app didn’t work for me

I did everything else besides this. Weirdly stopped being greyed out and it worked. Jesus I thought it was only me. Thank you!