No access to DLCs owned (3931107)

Platform: Windows 11 PC
Edition: Premium
Account: Solo account
PC GPU: NVIDIA GTX 1660SUPER
Peripheral: Xbox One Controller
Settings: Custom
Xbox Settings: None
Attempted fixes: Rebooted game and OS multiple times
Content Update: Most likely came with Series 31 Update

Since the Series 31 Update, the Premium Badge doesn’t appear next to my username anymore. I’m unsure why this happened since I’ve pre-order the Premium Edition and there was no issue until now. I’ll be sending a ticket shortly.

Screenshot from today:

Screenshot from October of last year:

Well, it actually seems that none of my DLCs I’ve got with the Premium Edition and pack later bought appear as owned in the game. They do appear as owned in the MS Store but I can’t use any of the content. That didn’t happen at the beginning of the winter season, but it surely happened at the beginning of the spring season, since the badge appears on the screenshot used for another issue I’m facing.

Lugar Tranquilo and La Casa Solariega player houses don’t appear as owned either.

3 Likes

That’s a very serious problem…
@KillerSpectre21 he needs your help buddy!!

3 Likes

Unfortunately I’m not a Developer so I can’t do anything.

@SyselSyslo

The best bet is to send a ticket to both Xbox and Forza Support and see if they have anything on their end.

Issues like this mean the game is unable to authenticate your DLC purchases and it’s often related to a temporary server outage or something like that.

Since this has been going on for an extended period then it’s definitely not a temporary outage and something has gone wrong with the account.

Hopefully support can take a look and see what’s up, Forza Support would be my first stop since you said the DLC is still marked as owned in the MS Store.

3 Likes

I contacted Forza Support about this issue yesterday and still awaiting a reply. I was, unfortunately, met with another issue a few days prior - credits from a complete auction were not added to my balance. They suggested a UWP game reset and reinstall which I doubt is going to be of any help since this is surely a server/account issue and not a client issue. The same goes for the DLCs not registering as owned.

I’ll be really glad if they’re able to fix this - at least the DLCs - when updating for Series 32. Sadly, this happened just before I wanted to buy the remaining packs I’m missing.

1 Like

:skull:

1 Like

The True Microsoft Experience

2 Likes

Fortunately, this is not an issue anymore. Well, at least not for me. I hope that those who are still struggling will get it fixed soon too. :pray: The support team has not replied to my ticket, but never mind that.

2 Likes

So i have bought the fxx-k evo, the ferrari track car, Italian exotics and horizon racing car pack, but recently (around a week ago) i tried to get in any car, but when i tried to it said “This is a DLC car that you have not purchased from the marketplace” and gave me 2 options “go to marketplace” or “remove car from garage” and i just dont know what to do and i want to drive my cars

Bug Info: i cant drive the cars i bought
Platform: windows 10
Edition: standard
Account: solo account i think
PC GPU: i dont know
Peripheral: i dont know
Settings: i dont know
Xbox Settings: nope
Attempted fixes: i have tried alot but nothing worked
Content Update: it happend before the update with the mclaren sabre


See this Bug Report:

1 Like

what should i do with this?

Vote on it.

There is no need to make double-topics for issues that have already been logged.

The OP also says a reinstall fixed it so you can try that while you’re waiting.

1st of all, a moderator in the forza discord server told me to make a new topic.

and wont a reinstall loose all my data?

Then he probably didn’t know that there’s already one here.

A reinstall won’t lose your data unless you decide to delete that too.

Before reinstalling do something that syncs to the cloud like downloading a livery to ensure you have the latest sync.

Once that’s done exit to free roam and let the game finish saving (look in the bottom right for the little circle).

Once the circle is gone then close the game properly and then uninstall the game.

When you’ve reinstalled and started the game you’ll have the option to sync off your Local or your Cloud Saves.

Choose Cloud Save and let it sync.

If you cancel the sync then it will delete your save, if you’ve been playing for a long time it can take around 30 mins or longer.

2 Likes

@tastetur I also strongly recommend creating a ticket as well, if you haven’t already. > support.forzamotorsport.net
They may not reply for couple of hours but your DLC access will eventually return.

1 Like

Bug Info: DLC cars I bought are unavailable
Platform: Windows 11
Edition: Pro
Account: grinsekatze3711
PC GPU: Nvidia GeForce RTX 2060 mobile
Peripheral: i dont know
Settings: i dont know
Xbox Settings: nope
Attempted fixes: reinstall game, reset Xbox app and Forza

I’ve had this issue since the summer of 2023. Connection issues, syncing problems, and non-working DLC cars prevented me from playing the game for months. When I returned to the game the week before last, I struggled to sync the cloud save state to my PC. It took two full days of troubleshooting to resolve that problem.

It’s difficult to say whether the DLC car issue existed from the beginning of this month, as some DLC cars initially worked. After a six-month break, I wasn’t sure which cars I had purchased. Since then, I’ve bought three DLCs, but none of them functioned correctly. So it took until the weekend before I noticed the problem. I verified my purchases through the Xbox app and followed a support guide to troubleshoot. This included updating, restarting my PC, resetting Forza and the Xbox app, and redownloading everything–multiple times. This workaround was successful at some point, and I was able to play with all my purchased DLC cars the day before yesterday–just in time before I wanted to delete the entire Windows partition and turn my back on Microsoft completely; a consideration that again seems quite attractive to me.

However, after server downtime last night, my DLC cars are unavailable again. I repeated the previous troubleshooting steps, but this time with no success. Consequently, I requested a refund for the three DLCs and gave Microsoft a warning that I would contact the customer protection office if they don’t resolve this issue.

My patience with Microsoft has reached its limit. The problems I’ve encountered with their products far outweigh those of any other products or services I use. I spend more time fixing issues on Windows than I do playing games or working on my Linux system. This week alone, I’ve wasted half my free time trying to get Windows and Forza to work properly. With Linux, I typically just click ‘Download and Play’ in the Steam Store, and everything runs without hassle.

1 Like

Unable to play any DLC including Hot Wheels and Rally. When navigating to the DLC I’m shown the Trailer and it states to install DLC. I proceed with selecting install and then I’m taken to the “Offer or Upsell” page that states that I already own the dlc. At this point the title somethings takes me back to the previous menu and other times it softlocks and stays on the infinite load screen.

Platform: Windows 11 PC
Edition: Standard + Premium addon bundle
Account: Solo account
PC GPU: NVIDIA RTX 3070ti
Peripheral: Xbox One Controller & MKB
Settings: Custom
Xbox Settings: None
Attempted fixes: Rebooting title, reinstalling game, reinstalling DLC, reinstalling all game files, resetting app, repairing app, reseting windows store, repairing windows store, installing on second pc and attempting use DLC.
Last Updated: 4/29/24
Verison: 3.642.644.0

1 Like

Have you tried logging in to the Xbox App? Or resetting/repairing it? It’s not likely that the Xbox App is the cause since it doesn’t work on multiple devices, but it’s still worth a try. If that doesn’t help, create a ticket on their support site.

Did someone find a solution for this problem? I bought the Forza Horizon 5 Premium Edition on October 21 and played the game on my Series X until last month, but now continue playing the game on PC. Sadly I’m having a problem playing both DLCs even though they are both installed. Every time I try to start them from the main game I am redirected to the Store. It doesn’t matter if I drive to the icons on the map or enter them via the menu. I have already logged into my Microsoft account and deleted old devices, logged out of the Xbox app on the PC and logged in again, moved the installation to another folder but nothing works. I also tried resetting and repairing the game in Windows.

Screenshot 2024-05-17 214314

Create a ticket on the support site. They may or may not answer but will fix your problem.