Forza wont update

We realize that sometimes things are posted in other topics…like the fact that I’m trying to figure out why I can’t get my forza 5 to update to the new track and car pack. but some of us do not want to scroll through 626 replies on a single thread to find where it was actually talked about and how in context it relates to helping my situation.

That being said with out sending me to the long beach thread would someone please address why I can’t update and how I can fix it?

Thank you

I expect this to be locked soon but there is an issue but there is a work around

This is what worked for me

Turn off console
Pull out power cable
turn xbox on
sign in
make sure you have background downloads active and xbox is set to “instant on”
check network connection and live connection
load game
once loaded quit game (home button, start, quit)
hold home button and press turn off
leave 10 mins come back and look at Forza icon on dash for it to be installing

If it isnt updating check on the game if it has already updated whilst it was turned off by looking for Long Beach in Rivals, if its not there, quit to dash, quit the game, turn xbox off and wait another 10 mins and repeat


thank you i will tray i will tell you

1 Like

Im having the same issue. Maybe overloaded servers or something?

Same issue here, I see there is a rivals event for it but I can’t access it and when I try it takes me to the purchase screen where it just buffers. They really need to fix this ASAP!

Thanks. I’ll give it a shot, and thank you for being quick before they locked it :smiley:

1 Like

I’m having the same issue, I’ll try tomorrow I guess.

I turned my Xbox off, then turned it back on after dinner to find that the title was installing the update.
I do not use kinect to turn the unit on so the whole “standby mode” thing didn’t matter. I also tried the hard reset by pulling power which did not initiate the update. What worked was what I stated above.

1 Like

Thank you, that worked for me.

1 Like

Friend told me make sure auto updates are on, quit the game and shut the console off. Wait a few minutes (about 5) and you will hear your Xbox turn on and start the update. Turn the console back on and wait for it to finish updating. Worked for me.

awesome! it worked! I don’t know why it worked but it did. Thank you!

1 Like

None of this is working for me!!! D:

This is a complete mess.

There is absolutely no reason for having to go through so many hoops.

Now my disc doesn’t work again just like yesterday. Why does this have to be so difficult?

1 Like

[Mod edit - WSD. Defaming]

Just because…

I’m trying a reinstall now

1 Like

My Xbox won’t install the update in Canada I was able to download the booster pack for free, but I can’t get the track to download. Tried restarting throughout the day with no luck. Left it I instant on, so here’s to hoping it will be installed when I get home from work.

Using the instant on and turning of the X1 helped for me… waited 10 minutes and when i restarted the X1 the update was instaling, thank you BDR Daz, it worked like a charm :slight_smile:

1 Like

worked for me too

deleted the file that I downloaded from the add on store

made sure that I had my xbox settings to “instant on” and “automatically download updates”

turned my X1 off for 10 minutes, and when I turned it back on it immediately started downloading the update


Tried everything still doesnt work for me either :frowning:

They should add just two thing to make it easily:

  • one button in settings to check updates for all apps and games

  • an option to check what version of the game is installed (so you know if your game/app is update to last version or not)