Cannot join Horizon Life

Hi All,

I cannot join horizon life, it just says finding session forever.

Before loading up Forza the Xbox App Network tab says my NAT Type is Open and Server connectivity is Connected, I can also join xbox party chats.

As soon as I open the game and attempt to join Horizon Online I noticed my Server connectivity turns to blocked and I can no longer join xbox party chat, all while the game is forever trying to find a horizon life session.

I have tried everything Microsoft suggest on their support pages and forums and yet no luck.

Anybody got any ideas??

Just to confirm, is this Team Adventure?

No this is just selecting ‘Go Online’, the box tot he right of the map

Can you run a speedtest and post your results please?

I am not at home at the moment but I can tell you I have 10Mbps down, 1Mbps up and 50 ping

Okay. So, are you playing Forza as a standalone application or via an XBox on the same network, via the XBox app on your PC?

Standalone application on pc

Things I have tried:

  • Set date time to off and then on again
  • Windows Update
  • Turn windows firewall off and then on again

I have also tried running all the following commands with restarts after each:

  • netsh interface Teredo show state
  • netsh interface Teredo set state type=default
  • netsh interface teredo set state
  • netsh interface teredo set state client
  • netsh
    int teredo
  • set state disabled
    int ipv6
    set teredo client
1 Like

I see that you have tried the windows update as well as the firewall feature.

Do you have an anti-virus program? Or even just a separate firewall program, other than the one that windows provides?

No extra anti-virus or firewall installed.

Thanks for your help so far by the way :slight_smile:

No problem at all. (:

When you get to your PC… Try these steps:

  1. Open the Start Menu then type ‘Windows Firewall’. Look for ‘WIndows Firewall with Advanced Security’ then open that program.
  2. On the left pane, you should see a list which should look like this:
  3. Click on ‘Inbound Rules’.
  4. On the pane located all the way to the left, click on ‘New Rule…’.
  5. Click on Program (although it should be already selected), then click ‘Next’.
  6. Click on ‘This program path’, if it is not already selected, then click on ‘Browse’.
  7. Search for the program then click ‘Open’, then click ‘Next’.
  8. Ensure the ‘Allow the connection’ is selected. It should be by default.
  9. Now you can select when you would like this rule to apply to the program… Depending on the connection type. I’d prefer you to leave all 3 selected. Click ‘Next’.
  10. You’ll have to name your rule, so just type something simple like ‘Forza Horizon 4’. You can leave the description blank.
  11. Click ‘Finish’.

Your inbound rule should have been created. If you look for it in the list, it should appear.

Now, you’ll need to do the same thing with the ‘Outbound Rules’ tab. Just follow the same instructions above. Make sure to check the list to verify your rule was created.

After you’ve completed creating your inbound and outbound rules, close the window.

Close any other open programs or files. Don’t forget to save any open work. (:

Next, restart your computer. There’s no need to shut it down completely, but you can if you prefer.

Try running the game. Post your results for me. I will cross my fingers and hope this works.

If it doesn’t, don’t lose faith… There are still a few more things we can try if this process fails.

Sadly that did not work

Okay. Can you PM me please.

Its not possible to start the game with Admin-Rights. I cant click on open after finding the FH4 exe for Firewall Settings. You cant do NOTHING. Microsoft is not able to make games. After 1 Week and 100€ payed its not possible to play this game. Last game for me. Such a shame…

I have the same problem with Horizon Life, here I have a picture with the error I’m getting



Hi guys, i have the same issue, but for me none of the online stuff is on. i made a video : - YouTube
(Everything is ok on the xbox network test)

1 Like

The same here…

Bro I found a fix,

Try resetting the xbox app. u can do that by pressing your windows button then press setting and go to apps and features and search for xbox app and then click on it, click advanced options after that scroll down until u see reset. that works for me.

[Mod Edit - All posts to this forum must be in English. Please translate your message before posting - D]

Reseting the xbox app isn’t working…