Won't go past "Press A to Start" screen

My game will not load past the “Press A to Start” screen and I have done everything I know to do to get it to work and it wont. Any suggestions?

“Everything” as in what?

I have also had this problem as of late. What I have done is restart the Xbone… it may take a couple times… I don’t know what causes it. I’ve clicked on the Forza5 icon with the disc on it and I’ve clicked on the other Forza5… sometimes it won’t go past that … press A to start page. But I always have gotten it to work.


Mine has been doing this since the Long Beach update. I have to hold the power button down until the Xbox completely shuts off. Just putting it into standby mode wont fix it.

I am having the exact same problem - I bought the game yesterday and was able to play the first 2 circuits, but ever since then the game hangs at the home screen after pressing A. the timer just sits there spinning, and I have left it for hours in case it was doing an update. I’ve tried shutting down and restarting xbox, deleting my entire forza 5 profile, and removing and reinstalling the game 3 times (not a short process!). I am at a loss to get it working - has anyone else experienced this issue and how did you resolve it? this is getting very frustrating!! thanks in advance…

1 Like

I’ve been having a similar issue but for me it only happens when i got from watching TV to playing xbox. What has been working for me is powering off the controller than powering the controller back on.

Unplug from the wall to hard reset the console, make sure the power supply doesn’t have any stored power in it when you plug back in. Just a power on/off won’t fix issues that come with the box needing a restart. See if that helps?

I was havin the same problem i just turned the power off at the wall for 20 seconds then turned it back on an that fixed it up…

It took me a good 15 minutes to load the “press A screen” then another 30 minutes to sync my saved game. I used a new Xbox and reinstalled the game when it happened. As long as the spinning load icon is moving it should be doing something. You just have to wait, depending on your connection speed and install status determines how long it will take.

Press xbox home button to go to xbox home then, press start on the forza window and then quit game, after that start the game again, always worked for me.

I have this happen, but only when I use my “Day One” controller. I think it’s dying. I’ve been able to get around it by just turning off the controller and turning it back on. A whole restart will fix it too, but this may be a little faster.