Win10 users, turn on Hardware-accelerated GPU scheduling!

It increases your framerate, drastically! I found it by accident, at Hot Wheels DLC, I usually had 80-90 FPS, after I turn on Hardware-accelerated GPU scheduling my frame rate keep stable at 144 which is my framerate limitation, I don’t know if it can do more.

But in Mexico, it doesn’t improve much, weird

my rig CPU: AMD 5900X, GPU: 4090

I don’t know why but for me, Hot Wheels runs horribly. I played it at launch with almost max settings and it ran fine. Now it keeps giving me slowdowns. I’ve done everything, from formatting Windows to changing stuff in the BIOS, to enabling HAGS, etc. I’m even using lower settings than before. I even lowered Raytracing but it’s and everything else to High but nothing changes. It runs absolutely fine in Mexico (apart from Guanajuato, which has been a mess since launch) but terrible in Hot Wheels park. This started happening after a specific update that I don’t recall. This game has been nothing but trouble for me.

I mean there’s clearly a massive issue regarding this DLC. My GPU is literally using 7.1gb of VRAM, I switch to Hot Wheels and it stays around the same but the GPU usage gets completely destroyed. Then when I go back to Mexico I get a massive increase in VRAM usage (from 7.1 to 7.6) and it stays like that. And I can notice that the game is not as stable as it was before exchanging maps. None of this makes any sense.

RTX 3070
Ryzen 5 3600
16gb DDR4 3600Mhz

1 Like