Performance - game takes a long time to load and sometimes may not load after series 19 update

Since the latest 4gb update the game won’t launch at all. I re-installed and it loaded fine the first time. Then I turned off the PC and now that I tried it it’s the same. It doesn’t launch, it just loads and then quits. Everything related to FH5 it’s been such a pain… Never again…

1 Like

Exactly the same problem here since the last update.I start the game, it takes ages to load, then it quits.It does not get past the first picture of the red car.Sometimes it takes multiple attemps to get FH5 to load, it took ten attemps yesterday,then one time it loads up and I can play, I see no pattern though. If the game starts it seems to be pure luck.

I have repaired the app, tried to start as administrator but it makes no difference.Running Windows 11 pro it is up to date, Nvidia drivers are also up to date.


Right now the only way to launch the game is to reset it from Windows Settings → Apps → FH5 → Reset. Then I launch it and it shows the window of ‘Syncing data’ and downloads again the data from the cloud for about 5 min and then starts fine. BUT if I close the game and reopen it, it doesn’t launch. I have to reset the app of FH5 every time for the game to work. It’s laughable… Who knows tomorrow may not work at all! These people are amazing… Every second or third update I have an issue…

By resetting the game you loose the graphics settings and you have to select them again. The controls stay the same, for me at least.

1 Like

Ok so now the game won’t launch at all! No matter what!

I was playing for like 3 hours, I turned it off and now I can’t run the game again…

Ok so it’s pure luck, you’re right. After 7-8 attempts it launched… omg

The game started first time earlier today for me, and I just tried again and it also started first time.Yesterday was totally different though with multiple attemps to launch the game.

The start picture with the red car to the Turn 10 logo, takes roughly 5 times longer than before the last update.The picture of the red car also reduces in size to around a quarter of the size after a while.This game seems to be doomed.

My game on pc will just not start easilly. I just attempted 7 times again to get the game going and it just closes during the start process, attempt 8 just failed…Yesterday it took me around 20 minutes to get the game to start up, failiure after failiure, then out of the blue it boots up. Fh3 and 4 start normally.

Edit. Attempt number 10 was successfull.

Same issue here. I’ve tried the “reset Microsoft store” trick, the “run as administrator” trick and the “uninstall/reinstall” trick. Same result almost every single time - splash screen loads, then just disappears.

I refuse to reinstall the game with my 4mbs internet connection.I am trying to start the game right now, 3 attemps and counting.This morning was 6 attempts before the game loaded, this is crazy man.I bet if there was a bug that prevented people from paying for the game etc, it would be fixed instantly.

Edit. attempt number 7 to start the game just failed.

Edit 2. The game started on try number 9, Yay.

The game is only starting randomly for me (PC MS Store version).

If it doesn’t starts it looks like in the following GIF (shortened version).

The actual process takes about one or two minutes.

I’ve watched the task manager and it starts with the GamingServicesUI.exe switches to Forza Horizon 5 and then just quits.

1 Like

That looks exactly like what happens to my game during start up, PlageBLN.

Have you had any replies from anyone that could solve this issue, here or the official support Zat?
The issue you are having would be unbelievably annoying/upsetting/irritating considering how long it has been for you

I would suggest more but I have run out of ideas and now it’s down to PGG/Microsoft/T10 to address the issue that the game is not working as per what would be expected considering , Mate so sorry can’t answer or address the issues more and I hope come next week maybe someone might be able too :pensive:

Two things I’ve noticed that could be somehow related.

A) If it’s doing the synchronisation (which it doesn’t always do) it’s doing it right at the start (that’s normal and how I know it) but since sometime it’s also randomly doing the sync on the main start screen ingame (that’s new to me). So maybe it’s a problem related to failed syncing?

B) Just yesterday I noticed that during one of the unsuccesful starting attempts one of my HDDs got woken up from it’s energy saving mode during the start (I could hear it spinning up). I’ve multiple HDDs just for storage purposes. There are no executables on there that are normally running in the background or so. All the relevant stuff is on an SSD. Forza has absolutely no business to touch these HDDs but it still did.
Not sure if and in which way this could be related but before the last update Forza was trying to randomly run something (named also ForzaHorizon5.exe) on various and changing HDD partitions. I know this because it always brought up a pop-up asking me to allow it to do so. IIRC we came to the conclusion that this could be possibly related to an anti-cheat check/protection. Maybe it’s related to something going wrong here?

No Len I had no replies that can help.I had expected that someone from pgg like Max might have answered.This problem trying to start the game seems dependant on lots of votes for this thread or it is just ignored, it is ludirous.Every time I try and start the game it is a fight to get it to load.

1 Like

I may have found a solution for the game not starting, I tried it 4 times and it worked 4 times.But maybe this only works for me ?

During game start up, after the picture shrinks to a smaller size, I noticed that if I right click on the game icon, it says start fh5, I found that strange, normally it just says close window. Maybe the computer is not racognizing the game is starting up ?? So I clicked on start game a second time, nothing changed the same picture was still on my screen, but the game started all 4 times that I tried it.

Having the exact same issue !

I forgot about this thread… This method works for me too!

1 Like

Double loading who would have thought!

my temp fix is to alt tab during the first load screen then seems to load fine…