Serious Bug FH4: Controller Buttons on XB1X not working after resume from Instant-On or longer pause

Hi! Since the last update around 26 September 2020, there is a serious bug on the Xbox One X version of Forza Horizon 4 when resuming the game from Instant-On sleep mode or after a longer pause outside of the game, at least while using the standard Xbox One controller.

I guess that getting ready for Xbox Series has led to adding compatibility with the new XB Series controller, thereby on resume accidentally loading the wrong keymap for the old XB One controller when reloading assets.

While the joysticks work, neither the map button nor the menu button nor the D-Pad do so anymore. A restart of the game is required.

There is also a second, slightly annoying bug, where the camera sometimes ‘whooshes’ back twice to the car when returning from a menu. This impacts visual slickness.

I understand the triple crunch of FH4, Series and Fable, but at least the controller issue is quite a bad bug, even if not a complete showshopper. Please fix! Thank you.

PS: I would gladly do beta testing for you.

It was the same with XBox S, but the second update fixed it. The second update didn’t fix the jerky bug though.

It’s the same with the PC version, the controller menu button stops working, and the keyboard can’t be used either, so you have to just close down the app, as there’s no way to access the game’s option to exit.


I don’t understand how something like this can get past testing. Both the controller issue and the graphics issue hit you within a few minutes, if you would be checking out the changes. I sincerely hope that FH4 is not in ‘rookie’ maintenance mode, while the A-Team is busy with Fable. FH4 is the ONLY open world driving simulator which Microsoft can offer right now, it’s a phantastic game, but getting sloppy like this is not a good sign.

FH4 is huge solution, butterfly effect can happen everywhere and testing all the combinations of actions would just take too much time. Additionally, there are issues related to production environment which could still happen. A solution could be to go for a pilote release with a limited group of players. Nevertheless, it has a significant cost and it’s taking the risk of leaks.

Globally, you cannot expect a company (M$) that considers your player profile does not need to be backed up (or sync secured ), to grant FH team to take money on avoiding this kind of issues to happen. It’s not dev issue, it is just rational costs vs risks.

While updating the game every month and despite most updates did come with issues, we never experienced a global unavailability of the game, that’s already an achievement. I doubt they don’t do the maximum to avoid bugs, being the one who failed a release on one of the major game of M$ is not something anyone wants on his/her resume.

Still the most frustration I have concerning updates is when it comes to things like car reset which was modified without discussing with player base, had 2 updates developed and released, and is finally worse than it was in its first version. That’s kind of fail and wasted effort that is not acceptable, for me, from such a team.

Or just have tests. But who cares about testing, right? :smiley: It’s not 1990 when development was wild west. Today everything is much easier and you can guarantee some quality.

I gave up thinking they do any testing more than a year ago.

The pandemic seems to have made everything much worse.

Since virtually everyone at PG is working from home, they must rely on their internet connections and VPN to upload changes and sync with the project’s CVS repository. That’s probably dead slow compared to working in-office.

The same goes for both in-house and outsourced QA and compliance testing, they too must be working from home.

But with that said, those bugs are horrifically annoying.

FYI since controller/wheel customization was always spotty at best on Xbox/PC, my own buttons automagically remapped on my controller, hitting B would bring up the map, etc. Restarting didn’t fix it, so I simply got into the controller menu and hi Y to reset to defaults, which solved my problems.

Issues with joining online games (spinning out of control like its trying to place your car in the world/at a owned property, etc persists but its not fatal, and goes away after 1 or 2 false-starts.

The problem is, on Xbox even this is not possible, because when the controller buttons stop working, there is no way to get to the settings menu. And anyway, I feel that this is a serious problem Playground must quickly take care of.

Same issue here on my Xbox One S and controller.

What seems to be a partial workaround for me is to “pause” the game before going off to something else like Twitch or Edge.

So, I hit the controller “menu” button and wait until the “view map/change car/…” choices come up. Then I switch to the other app in the usual way.

This might require some others to try this out as I am not sure it works all the time.

Definitely not working for me on the Xbox One X. This has been going for over a week, with unfortunately no official info whatsoever.

This happened to me once prior to you starting this thread, I’m sure it was on the first day up that update/new series (using the older elite controller on a one x console). I pretty much just attributed it to the ghastly condition of the device as I play with a crushing grip to the point where the handles break open and I have to wrap them with blue painter’s tape so I dont slice open my hands on the jagged plastic). But now it’s happened a bunch of times since friday or saturday and gets progressively worse it seems, with frequency of instances being much closer together.

Last couple times i just gave up and left the machine off.

Happened a couple of times to me today too, once where I couldn’t even enter races which is a first.

Poor, no need for a long waffle it’s just downright poor.

For me it’s happening even just letting the xbox on, going to xbox menu to look for a message, I switch back to game, get out of menu and then I have a message connecting to session or something like this and no way out to menu.

No one tried to reinstall the game yet ?

Same on PC, all you have to do is alt-tab to something else, then alt-tab back, and the menus can no longer be accessed.

No update from the developer yet? This is happening to me every single time I resume, have to close the game completely and reload to be able to play

Someone posted that the October 2020 update has been pre-scheduled. Perhaps they are rolling it all into one update, as it halves beta-testing.

Then perhaps, they just couldn’t care less.

I alt-tab a lot because there is so much waiting around in FH4, and it still works most of the time. But a few times today I’ve had to force quit.

The latest FH4 hotfix / update from 13/14 Oct 2020 (perhaps in combination with the same-day Xbox One update, although I don’t believe this to be the case) seems to have fixed the camera jump issue and, most importantly, the controller button issue.

Even though we are constantly told that the Playground team do not read this forum (whyever not? Other support channels seem pretty defunct and more a fig leaf and a method of shielding stressed developers) I would like to say:

Thank you!