Forza 7 closes at splash screen

I try to open MotorSport 7 and the slash screen appears for a little while and then it closes. Ive ensured windows is updated i have reset the application. I did a clean boot. Ive made sure that the game is up to date and that all of my drivers are up to date. I even tried downloading a free DLC because apparently this has fixed the issue for some.
System specs

Ryzen 5 1600
Radeon R9 290x
16 gigs of ram
windows 10 PRO

Ran the event viewer and this is what it says

Unable to start a DCOM Server: Microsoft.OpusPG_1.0.119.1002_x64__8wekyb3d8bbwe!OpusReleaseFinal as Unavailable/Unavailable. The error:
Happened while starting this command:
“C:\Program Files\WindowsApps\Microsoft.OpusPG_1.0.119.1002_x64__8wekyb3d8bbwe\forza_x64_release_final.exe” -ServerName:OpusReleaseFinal.AppXhz3m1thxb88yczd2ax0k426vzefwnnmc.mca

The same thing happens when i try to launch Horizon 3. Ive re installed Horizon 3 to see if it would fix this issue and didn’t. So i saw no point in re downloading and installing Forza 7. Any help would be great.


This is a known problem and the answer has been posted numerous times:

Click start, type services, hit enter

this will bring you to the services screen.

Scroll down and find “Windows PushToInstall” service

Double click on it, and start the service, it will probably be disabled. Set it to automatically start.


This is not a functioning solution for Error 5. If it were, my game would have been working 7 hours ago when I started troubleshooting this problem.

1 Like

Have you tried the following;

Error indicates that you wont have required privileges to install the application to that particular system drive. Right-click on the application(.exe) file and select Run as administrator installing the same. Do follow the below mentioned steps and see if it helps.

Method 1:

Open the properties of the main User Profile folder where the files are located (such as Documents, Pictures, etc.). You can open the properties of a particular folder by Right-clicking on it and select Properties from context menu.

Go to the Security tab and click Advanced. Check the box at the bottom of this window. It is labeled “Replace all child object permissions with inheritable permissions from this object” and then click Ok.

This does a one-time action that replaces the security on all the files/subfolders. It’s one-time, so you won’t find that box checked if you peek at it later. Please let us know if it’s working

Method 2:

  • Press Windows Key + R, type netplwiz

  • Click and highlight the User profile, which you want to make administrator

  • Click on Properties, then select the Group Membership tab

  • Select the Administrator, Click apply/ok.

All the problems with windows store that i’ve seen all relate to permissions in some or another. Usually access to the folder the game is stored in and then they rear their ugly head whenever you update.