Voice chat finally working on PC and OH GOD I WANT MY SILENCE BACK

how do I mute all the players?? this is so annoying I can hear them breathing, eating and blasting their music. I WANT TO GO BACK

6 Likes

IKR !!??
I mean, WTF were the people at Playground/Turn 10 thinking when they just opened this box?!
When I’m in my convoy with my mateys I can sometimes hardly hear them over the smacking, slurping, burping, yelling or laughter of complete strangers (which on the other side can’t hear us, so we can’t even tell them to turn off their goddamned microphones!!!)
And worst of all, our convoy doesn’t even uses the in-game/xbox chat! For months now we were using T3, discord or steam chat and were absolutely fine and happy. And now this SH!T ?!

Please… for the love of god… HOW THE HELL CAN I MUTE THOSE OTHER PLAYERS IN THE GAME???

6 Likes

1.Install VB-Cable ( VB-Audio Virtual Apps )
2. Open Sound control panel
Press Win+R
rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl,0

  1. Set “VB-Cable” as default communication device
1 Like

thanks for your answer.
but to be honest, its not really clear to me how this would help with this specific problem?

I think it would be helpful if you explained in layman’s terms what this achieves, before anyone thinks of trying it.

Bear in mind we can already mute our own microphone in Forza (it is possibly muted by default, I can’t remember). We want to mute everyone else’s.

FH4’s Voice chat uses a communication device, which is the principle of assigning a fake device to make the voice inaudible.

1 Like

deleted

Please tell me they haven’t been this stupid not to include a mute option. And a permanent ‘mute all’ option I set once, not one where I have to set it each time I play the game (like streamer mode) or worse, select players manually and mute individually (yes some games actually make you do that).

5 Likes

please… just don’t get me started on that s***! EVERY SINGLE time I start the game I gotta go and manually activate the streamer option just so I won’t be pestered with the same lame music throughout every single one (of the many many many many…) cut screens!
but no, as far as I can tell there’s no switch to turn off the chat function. or at least I haven’t found it so far

5 Likes

I have my mic muted since ages ago. There is an option to deactivate mic in the game options, and if you cant, you can do it from the windows audio configuration.

Yeah, I’ve been laughing the past few days at the number of people who leave their mics on and force their teammates to have to listen to the ambient background noise of their homes. It’s really distracting and detracts from the racing experience every time. Feels like being back in the old days of Xbox 360 Live.

It makes me want to plug in my own microphone to tell them to turn their mics off, since I don’t know how I could mute them otherwise. Trouble is, not all of them speak English, so even that’s not always going to be an option.

deleted

I think I found the solution:
go to https://account.xbox.com/Settings and block “Others can communicate with voice, text, or invites”

2 Likes

that sounds like something that could actually work! i’ll try that tonight.
thanks a lot

Thanks! I hope this works the next time I go online.

I believe I’ve said you didn’t want to hear anybody anyway. Start a party by yourself in the Xbox app. No mute on Xbox either. You could in older Horizon games.

For once, xbox is beating PC, I just start a party and mutes them all in a single shot.

I have witnessed that some people were muted for me without I muted them. I suspect that if one is muted by anyone, it will stay muted until it goes to unmute itself …

I dont know what problems have the pc users in this forum, but I NEVER HAD ANY PROBLEM IN PC MUTING THE MIC. That option always worked fine for me. Every single person is muted in my end. And i never had to touch anything else, just that option ages ago.

So yeah, pc users if i were you i would check your system because you guys have something wrong that is messing up with the microphone.

Well, it was working fine for past 2+ years, but 2 weeks ago (Hot Wheels update?) something changed and I can hear voices.
From yesterday I’m using Wasssaaaa suggestion and haven’t heard anyone. But I was playing only for 1 or 2 hours, so not long enough to be 100% sure if it worked.

Just start a party by yourself in the Xbox app on your PC… does it not let you do that?