Top Gear 1st Challenge

My friends and I are trying to play the very first challenge in the Top Gear event and we are getting to the scene where the yellow Lotus is driving and then we get an infinite loading screen. I have spoken with Xbox Support and they are saying that the problem is on Turn 10 Studios end with the update that just released yesterday. Can someone please help me out?

Tried it not long ago and it is doing the same thing, i gather there will be an update to fix all the quirks the new update brought with it in the next few days or so.

Some new bugs got patched in it seems, you’ll just have to wait it out for now.

The QA testers must have been out.

… which in turn, will break other things, if past history tells us anything.

I went to go check now and still no fix.

I cannot finish the top gear event on Forza horizon 4. When Chris Harris stops talking, the loding sign on the lower right stays there forever while the yellow lotus just drives by itself then hits the brakes, and stayed there forever. There is no controller response except when you hit the Xbox button. This is a common problem, I checked on Reddit, and everyone has this problem. Can you fix it please?