Thrustmaster TX- shutting off after calibration

I just bought a Thrustmaster TX and used it a good bit this weekend. After 2 days of use I have encountered the follwoing problem: When I turn it on it goes through the calibration (wheel spins left and right) and when it’s finished, the lights go out as if the power was disconnected. This happens regardless of whether it is connected to the Xbox or PC.

I tried soft resetting the xbox (hold button for 5 seconds, unplug power cord for 1 minute, reboot) and all kinds of different power on/connection routines, but nothing has solved the issue.

Anybody else has this issue? Is it a dead wheel, or is there a simple reset or something to fix it?


My wheel is working again. I contacted Thrustmaster customer support and they gave me the following procedure to try before replacing the base unit. It was step #4 (usb connector) that solved my problem.

Please follow these steps to try solving the problem encountered with your racing wheel:
1. Plug the wheel straight into a wall socket.
2. Make sure that the other end of the power cable is firmly plugged in the back side of the wheel’s base.
3. Make sure that the Xbox button from the right hand side corner of the wheel base is not pushed in and stuck like that. You can push it and the button pops back up.
4. Disconnect and reconnect the USB adapter from the round socket located on the cable that links the unit to the PC or Xbox One.
5. Connect the wheel to the computer and see if the LEDs from the device light up and if the wheel calibrates. In case it does please check the wheel’s functions under Game Controllers panel, as shown here:
6. In case the wheel is not seen please reinstall the firmware back on following the indications located here:
7. Just before you hit “OK” to install the firmware please take a screenshot and attach it to your reply.
Please reply to this email and inform us about the results that you have obtained - as detailed as possible.

1 Like

Thanks for the feedback. :slight_smile:

Sorry, I’ve not been on here a while. This is a common issue and occurs if the USB connector doesn’t have a good connection to the cable (the round brake-away connector). All that you need to do if this happens again is disconnect and reconnect it.

Thanks, you’ve just solved the same problem for me.

I had this problem last night and was able to fix it, but now my wheel (Thrustmaster TMX) has a jammed in Xbox guide/home button. Any ideas?

My tmx home button did the same thing.I used a very sma;ll drill bit and drilled the center of the button and put a small screww in there.Now it can be pulled out.That was the first step.I found a small piece of flat plastic (popsicle stick shaped but only 2 inches long and drilled a hole in either end .I drilled a small hole beside the button to the left,one 1/2 inches over from the button.Using a rubber sink tap washer I attached the left side of the plastic stick with the washer rasing the left side of the stick to be even with the xbox buttonb top when not pressed in.Then put the screw in the xbox button hole and bingo!! Since the left side of the plastic is raised by the rubber washer the button attached the the other end it wants to stay in the out position.I was gonna return it but the new one will break anyways so I fixed it myself.