Still not able to race online (#7)

I know I’m not the only one but how do I get to race online, all I ever get is the same error message stating error connecting to server data or something like that. Is there a fix coming, have turn 10 said anything about it?

Same problem here not been able to connect to any multiplayer since early release. Get the msg online servers not up and running yet try again later. I’m in Norway have 10 megabit up 30 down. This is frustrating can connect fine to the other forza games.

I cannot get online either. I havent been able to get online with Horizon 2 either. I have invested a lot of money on the premium versions of the game. Please can anyone be of service? Kansas City, MO

Yes, same problem here! So frustrating.

Glad I paid £81… I was looking forward to some good online racing before all the idiots got on…


I’ve been having this same problem since pre-release Wednesday morning. I’ve tried to get a response here and on twitter, and shockingly I’ve heard nothing at all back. Seems pretty on par for turn10.

Hi folks,

We are aware of the issue that some players are running into with MP matchmaking and are investigating. I don’t have anything new to report but I wanted to let you know we are looking into it.



Thank you for acknowledging this cry for help :blush: can’t wait to get online!

Any news?

I can’t even get single player to Load.

Hell I can’t even get the game to get past the initial start up screen.

Don’t understand why every time a game is released I spend my money just to be disappointed and not able to play

Game was fine for me at launch but just seems to get worse over time.

I really hope this gets fixed in hours, and not days. Missing out on friends hosting club races tonight.

Paid $100 for ultimate. Pretty lame guys. Can we play the game please?

1 Like

I found a workaround that worked for me and is working for others. On your xbox, go to setting > network > advanced network settings > DNS and then set it to googles dns servers ( and

This doesn’t do anything for me. I’m still waiting to try multiplayer for a week now.

Same thing. Changing the dns did’t do anything.

Failed to start Multiplayer

Multiplayer is currently unavailable. Please try again later.

Hardwired LAN


This is becoming a joke. I paid $100 for the ultimate edition and Turn 10 doesn’t care that I still can’t play online. I’ve been playing forza games since the first one and this is just pathetic.


ive been able to get on. had to change my dns though

i did 8,8,8,8 & 8,8,8,7 and its worked