Rally Adventure troubleshooting issues

I use the Series S and it will not even launch the game. I cant even drive in the base game, so this logic doesn’t apply.

As title implies.

Attempting to intro the rally Adventure, and once it gets past the 1st cut scene, where I presume I would be put behind the wheel, the game crashes to dashboard. I’ve done multiple full restarts, and am currently attempting a reinstall of the expansion.

As I’m seeing reports of issues with tunes, I’m also going to attempt switching to a stock vehicle…

And no luck. I see that 1st scene, get told to get in the truck, the begining of the next cutscene starts, bit then instantly crashes to dashboard.

For diagnostic purposes, as noted in the title, I’m on a series x, so there should be no hardware issues here

Edit. Support ticket submitted, we’ll see what happens.

1 Like

It actually didnt install properly so i have to reinstall it through no fault of my own. This doesn’t mean the base game shouldn’t work though. This still could be an error so watch this space.

Device: PC
Version: Microsoft Store

This is a list of issues with the game subsequent to the update/rally adventure DLC

  1. Pressing the pause/Menu does not Pause the game during races against AI… After entering the menu the AI continues racing (multiple race formats)
  2. In Photo Mode the race does not pause… the AI will continue racing despite entering photo mode (multiple race formats)
  3. Rewind is glitchy it does not stop after rewinding… it rewinds and then unwinds (goes forward)
  4. view basket (button) is no longer available in upgrade screen…
  5. When you choose to view basket before existing upgrade store the basket is empty
  6. Trying to use ANY tune saved prior to update causes the game to CRASH
  7. “Win all Horizon Raptor race events” accolade is glitchy…

I am having exactly the same issue and just don’t know how to fix the problem having done so much research online. I had initial problems even completing the rally download but finally thinking I was good to go I am now constantly crashing at the same point as you are. Have waited way too long for this expansion and now unable to play it. Very frustrating and hope your ticket will get issue or answer for all with the same problem soon.

My FH5 Rally Adventure expansion map is missing the Goliath race.

XSX

Rewind went a bit crazy.

Would rewind but immediately go forward.

Rewinding again had the same result until game crashed to Xbox dash.

Hasn’t happened since

Follow up

Not the ideal solution, bit did a reinstall over night, and that has rectified the issue

Issue on XBOX Series S: Attempting to intro the rally Adventure, and once it gets past the 1st cut scene, where I presume I would be put behind the wheel, the game crashes to dashboard. I’ve done multiple full restarts,I have reinstalled the expansion 2 times without succes starting the game, now I am reinstalling the whole game :frowning:

The countdown timers for challenges such as H2-GO don’t pause when the game is paused or if you reload, meaning it has to be done in one attempt.

[Staff Edit - see the top post, text must be in English - TTMM]

By design, hardly an issue. They’ve always been like that

DLSS3 seems to be bugged also :confused:
NVIDIA DLSS 3 Is Poorly Implemented in Forza Horizon 5, Causing Worse Fluidity and Artifacts (wccftech.com)

with rtx 4090 it s not really smooth when we enable DLSS3 , really hope a patch soon

Hello,

Since the rally adventure update, my game doesn’t go past the home screen… It loads my profile and it gives me the options to continue, options or exit and when I press continue it just freezes but I can still hear sound. It’s for PC

Any ideas?
Thanks!

Its happening here too. Im only acesse the game after a few tries. Some of my friends are have this issue too. All of ours play on PC MS store versiom

I installed the new rally adventure dlc and update now the game won’t get passed the main title screen with out crashing I’ve uninstalled the dlc but it keeps happening

I’m getting a ton of stuttering during gameplay in the new expansion, have tried completely uninstalling my AV to make sure it wasn’t causing issues, disabling overclocks, triple checking drivers are completely updated and it was still persisting even on Very Low graphics preset after a restart of the game and my PC. I’ve uninstalled the game and am reinstalling it entirely to see if the issue resolves after that but if not then there’s definitely something weird going on. Normally play at everything maxed for graphics settings with 4xmsaa at 1440p with a 7700k @ 5.2Ghz and a 3090ti at 2,145Mhz and get 70-120fps and was seeing dips into the 40’s with seemingly random stutters. Even knocking everything down to Very Low I was getting dips from 165fps to the 80’s.

Anyone else having the same problem or is this just me?

1 Like

I’m also having issues getting the game to load. It gets to home screen and I have the options to continue, options or exit. If I press continue it just gets stuck and never loads. This is on a MS PC version.

However I’ve found a way to make it load. After pressing continue and waiting to see if the game loads, if I press the Windows key on the keyboard and then load a browser then alt + tab back to the game the game will carry on and load as normal. Alternatively you can have a browser running before starting the game and then just Alt + tab between it and the game.

Prior to the update I had no problems.

Hope this helps.

2 Likes

As an update to this post, uninstalling and reinstalling all 160gb of the game did get rid of most of the stuttering but not all. I have no idea why it’s happening and have done everything I can possibly do to troubleshoot it short of reinstalling windows. Between this and not being able to access tunes I made that I poured hours into whether I’m in the DLC or back in Mexico, I’m going to be taking an extended break from the game until it’s hopefully resolved. This is inexcusable to me.

1 Like

Platform: Xbox Series X
DLC: Premium Bundle

Issue:

I can’t launch the new DLC and xbox believing it not installed.

Symptoms:

I have download and installed the rally expansion (18gb) , gone to launch the the DLC from location marker on the main map and It brings up unskippable intro video for DLC

Once the video is over, it is bring up window showing purchasing options and clearly states that I have ownership of dlc and press A to install.

When press A, xbox is going back to dashboard and showing 18gb update installing in about 3 seconds ( 0% to 100% percentage bar ) and then returning to game.

When it returns to game it fail to launch the dlc and return to main map where you press X to enter the DLC marker in first place.

In effect stuck in loading loop going nowhere.

First impression is I corrupted the download and somehow screwed the installation, however I have deleted and rerun the update three times now and it still doing same thing.

Any suggestion would be appreciated.

Finally if this post is posted in wrong place , please feel free to move it to the correct location.