Performance - Shader compilation on every startup with Nvidia GPUs (1757774)

Bug Info: The game is constantly optimizing shaders upon every launch of the game, no matter of in-game settings and Nvidia Control Panel.
I’ve got my GPU swapped a few months ago from AMD to Nvidia, so I can’t tell exactly from which update the game is suffering this bug (most likely since Release)
I’ve noticed the compilation itself is slightly quicker with shader cache size set to Unlimited.

Problem doesn’t exist on AMD GPU’s since 23.11.1 november driver update
My GPU: RTX 4060 Driver: 552.12
CPU: Intel i5-10400F
Game’s running on system partition.

I have RTX 2080 and this happens to me too every time I launch the game - from the day it was released :slight_smile:

With this latest update I also still have these shaders, I have an RTX 4070 Ti

That’s only suggestion, but see if there’s any driver update for GPU, if not, then try older drivers.

They recompile on last 3 driver updates either, with clean shader cache folders etc

A thing to point out is that the “attempting to sign in” screen is taking longer than usual because of those shaders compiling in background. Oddly enough it signs you and loads your profile save faster if you boot the game and leave it unfocused (for example browse Discord) and that’s the result of my screenshot in original post.

Then we can assume it’s problem on game side, I played only once after update so idk if AMD also have similar problems. Gotta try it tomorrow

Same problem started with Update 7. Optimizes shaders every time game is started, then freezes in an infinite loading screen. Never happened prior to Update 7. No changes in hardware. This problem is on the game side, not the user side.

On AMD RX7900XTX game starts normaly w/o shader compilation.
Maybe theres some problem with nvidia drivers, try driver clean instalation maybe it will help.

Same here with nvidia 551.86. Didn’t update yet cause I’m playing other games with shader caches and I don’t want the stuttering back for them by upgrading my driver already until played through.
Why isn’t even partial progress of Shader Compilation being saved? I don’t understand the devs. And do they even test what they release? :frowning:

I have been playing since day one, and I have not had one start up where it has not compiled shaders. I have a 2060.

Driver: 552.22

PC. Steam. Premium edition.
GPU - RTX 3080
CPU - Ryzen 5 3600

I am having consistently longer shader optimization times when I attempt to play the game. This morning it took 12 minutes to optimize the shaders, and after a restart to change my GPU settings back to default, it took 30 minutes to do the same.

Before I had tried playing the game today, shader optimization went from a handfull of seconds to a minute or two, and this morning, 15 and now 30.

Any help in resolving this would be appreciated.

Thank You.

I FOUND A POTENTIAL FIX ON MY END!

I have to make sure the game is the primary window. Occasionally my Edge Search bar will be the focused window, and when that happens every Microsoft game (it doesn’t happen with Elden ring, that just will not start) will run at 30fps or take for ever to start up. I’ve turned the search bar off and got the game back to being the primary window. Lets see how it loads?

Yup. The window being in the background is what did it.

Sorry for the false alarm.

Yesterday I tried to enhance anti-aliasing by using settings from Nvidia Control Panel… and I broke the game :sweat_smile:

Time of compiling shaders on start-up went from ca. 15-30 seconds to 15-30 minutes, it also made loading times in-game much longer than before. Unfortunately, reversing settings in Nvidia Control Panel didn’t help so I’m reinstalling the game right now.

EDIT: Fortunately, reinstalling the game fixed the issue, time of compiling shaders on start-up is back to normal now (which is, however, still longer than I’d like :wink: )

Update 8
Driver: 552.44

2 Likes

Same happens to me since the launch with my 3070.

Tried multiple drivers, unilimited shader cache in nvidia control panel, no luck.

And there is still a memory leak somewhere in the livery editor. After spending some time creating my designs fps even in the main menu drops from 60-80fps to 20-30.

Tengo una RTX 3060 mobile y me sucede lo mismo