Forza took too long to start error message

Every time I try to play forza it will not Load.

I keep getting this error message

“For some reason forza motorsports 6 took too long to start. (0x8027025a)”

I just want to play the damn game.

What can I do to actually load the game and play?

Damn bruh :confused: n I’m mad I can’t hop online, private or public

Look in the console Settings and System to see if there is a console update available.
Restart the console by holding the power button; when it restarts you should see the green Xbox screen.
If the game still doesn’t start try going to My Games & Apps, Manage game, and uninstall the game and reinstall it.
Report back with results.

Already tried all that. Nothing is working

Just tired restarting the console again. Now it won’t even come on

Restarted for the 3rd time and it started to work

Everything is lagging so bad though.

Guess I spoke too soon. Couldn’t even finish one race and my entire Xbox crashed.

Now it’s doing the same loading too slow bs

Is this a digital or physical copy of the game?


Quick summary:

  1. Hold the power light button thing to turn off your Xbox one until it fully turns off.
  2. Unplug power from back of Xbox one for 5 seconds.
  3. Plug back in and start your game

Stupid as it seems it will work its clearing the cache from all the apps and games you’ve been playing and it gets overloaded and does this!


This is a hard reset and should be told to everyone that buys an xbone

I had the same problem with FH3 just now. Came across this thread and followed the above advice. Worked a treat. Thanks!

Correct - hard resets can be a life saver although you don’t need them too often if you’re already in the habit of quitting everything after pulling out and doing a full shutdown which requires killing power to the brick as well.

1 Like