Forza 4 Horizon Won't Launch (recent fixes not working)

Hi there,

I bought Forza 4 Horizon about a week ago. When I launch the game it opens the splash screen and either hags for 2 or 40 seconds and closes. I cannot fix this issue even after following these steps:

  • disabling running processes such as like Nvida experience anything that has an overlay or similar to afterburner etc etc.
  • re-installed the game (x2)
  • Logged in as admin account and loaded win app store , logged in account and hit install.
  • updated all drivers (GPU etc)

I am completely lost. all the fixes and solutions found via google do not work for me.

My set up is I have installed the game on my second hdd, but dont think this should be an issue.

If anyone could suggest anything else that would be great as i’m lost and really want to play the game.


1 Like

I know you tried everything but, what worked for me is uninstalling WARSAW, i hope you fix your game, its a good game, but dont expect a answer here, nobody from t10 helped me, some random user solved my problem.

I haven’t been able to get past the “press enter to start” since the 10/10 update. So if your version is either 1.197.396.2 or 1.197.899.2 you probably have the same problem.

99% of the suggestions on the forum are utter rubbish. Their support site is also fabulously broken too, just try signing in with the password you just created too.
I have a ticket open #5652 but I expect that Just Cause 4 will be out before I get to play this game again!

Anyway, you aren’t alone in your disenchantment.

Strangely, the advice to downgrade your NVIDIA drivers has disappeared I wonder why that is…