Cant connect into Online ( PC )

So guys… its not my problem, its a problem of a mate.

So he can start the Game without any problems but he cant join my convoy …

In the Xbox App it says : NAT-Typ : Middle , Server connection : Blocked.

We tryd everything what we found in Youtube… Troubleshoot and so one but nothing helped.

Hes from Germany and he uses a “Fritzbox 7430 Router” … if anybody can help it would be awesome ! we are testing it since 2 days and still same problems.
dont know what to do now…

1 Like

I believe there are some “Teredo-filters” or something you need to disable on fritzbox routers, found some posts like that while searching for a solution.

Click “Internet” in the FRITZ!Box user interface.
Click “Filters” in the “Internet” menu.
Click on the “Lists” tab.
Disable the option “Teredo filter enabled”. If the option is not displayed, enable the Advanced View first.
Click “Apply” to save the settings.

I have the exact same problem btw (Moderate NAT, Blocked server connection) and i’ve tried every fix there is but nothing seemed to have worked.

Well he did this aswell alrdy… I think toredo is not the problem, something else is blocking the connection.
We tried mutliple solutions but nothing workd to be honest… thats so sad, I mean u pay like 100 euros for this game, but nothing works wow.