Wheel to sensitive at 900°

Using G25 on pc i put the rotation at 900° in the profiler. When i go ingame and test it with telemetry it shows me that it uses all 900°.
But when i’m driving or racing the green bar never fully leaves the center line. It feels way to sensitive.
I turned the steering sensitivity all the way down but it still feels like i can turn like crazy. I don’t know what to do.

Wheel Sensitivity - 0
If that doesn’t change anything then you got the settings not saving glitch thing.

I had the save glitch but i fixed it with the demo files. When i change stuff in the advance settings it does save.
My game isn’t set in english but i assume the wheel sensitivity is the opton at the very bottom?
If yes i already tried that and it does feel better but it still feels like i barely have to turn the wheel in to go into a cornor.
Playing asseto corsa or other racing games i have to much more of the wheel range. Is this just how the game is?

Yeah it’s the setting at the bottom but you should be noticing a huge difference. The settings are all over the place atm anyways and a lot of people with Logitech wheels are having all sorts of problems. Centering and FFB udersteer settings don’t do a single thing for me on a T300 so its hard to know what to trust atm, but like you i’m also trying to get it as close to Assetto Corsa as possible and for the most part i kinda have. Will leave my settings below not sure how well they’ll go for Logitech though. If your still not getting the wheel range you want my trick in FH3 was increasing toe out on the front haha.

Make sure yous have vibration off. Forza Horizon 4 LP EP13 - FIRST Thrustmaster TX Drifting + Wheel Settings | SLAPTrain - YouTube

Got my settings almost at a Assetto Corsa level on a T300 @ 900 on PC.

Vibration- 0 (make sure this is off!)
FFB - 55 (change for overall strength, lighter will feel better in corners and should stop wheel clipping)
Center - 0 (does nothing)
Wheel Damp - 0 (add to taste)
FFB Under - 0 (this also does nothing and is always on?)
FFB MF - 100
Wheel Sensitivity - 0 (PC only setting, setting this to 0 should match wheels rotation setting)

Thanks for the tips, can I ask are you on a console or PC?
Despite trying everything that I’ve learnt over the years I cannot fix my T300 from using combined and mirrored steering ie. steer right and the car turns left.
Oh yeah I’m on PC


Haven’t had any issues like that before. Only things i would check is make sure the wheel is in PS3 mode, and check FH4 settings. I run it in combined steering and haven’t had any issues. I would assume if all your settings are correct then its just Forza being Forza and maybe try the “My drivers and firmware are up to date, but the game won’t recognize my wheel. What can I do?” steps here https://support.forzamotorsport.net/hc/en-us/articles/360001988268-FFB-FAQ to reset everything and try again.

DON’T change the wheel sensitivity - it’s broken, anything bar setting it to 50 and it gives a step change in the steering response mid-corner and feels godawful and inconsistant (only tested with a PC though).
The steering linearity setting however works fine and gives a nice natural curve - so you can use that if you don’t mind non-linear steering, somewhere around 25-35 should do it.