Last Part of new Forzathon F40C Challenge (Xbox)

On previous challenges there has been a count of the mileage you have done. As there is no counter on the 24 mile drive challenge for the F40 C, this is a serious oversight due to the inability of the game to record all the mileage (up to the last 10 miles drive at least), on Xbox at any rate. I suppose I’ll need to resort to my repeated jumps at the PR Stunt near the Festival site.

I completed this last night and checked my progress on the counter more than once. That’s on xbox too so not sure why you’re not seeing one?


Have a quick run around Goliath. It registers near the end. Well it did for me on an XB1X in the UK.

I have/had a counter down near the bottom where it showed for example 10.4 of 24 miles

Had this challenge completed in less than 5 minutes

1 Like

Do a few lengths of the motorway. It took literally just a few mins when traveling at 300+ km/h.


Abaout hour on motorway progress abaout 2km so far even when driving 400km/h dont get any progress.

That’s messed up. For reference, I’m on an Xbox One S.

What settings do you have your xbox on
If you have the X try performance mode

Yesterday I powered my F40C with ~400km/h over the motorway and it didn’t register much. After 5 runs I’m somewhere around 0.7/24 miles - so basically nothing. Xbox One X, Germany.

Mine is working but a fix I’ve heard that works is changing to 30 fps in settings. Give that a try Rogs.

Made it to 12 miles… on 60 fps. That was an incredulous amount of driving. Switched to 30 and it was done as fast as its should be (PC here). Thanks for this.

I wonder if this effects the overall mileage of cars?

On Xbox One X, I normally run in 60fps mode, and it wasn’t working. I changed to 30fps mode and it worked correctly. It’s much quicker to change the setting, restart the game, then change back, than it is to have the total increase at snail’s place in 60fps mode.

30fps mode is horrific. It’s not just the frame rate, it’s the artificial motion blur, you can’t see a thing anywhere on the screen whenever you’re turning.

Same… or worse for me on PC… Drove around for almost 40 minutes… Now at a mind blowing completion level of 0.22 miles

Broken, untested stuff

I’ll try the frame rate thing and see, but wouldn’t that just say it all… Buy a PC for better graphics and faster fps, and be forced to slow down to half of Xbox speeds to get the game to work…

reducing frame rate to lowest setting worked for me, but only after restarting the game…

how anyone figured out this work around is beyond me… kudos to the above poster… Shame on PG… another bug for their list

Hello Fellow Racers,

I was having same problems doing the weekly challenge but finally figured it out.

You need to have your speed constantly above 400 klms/h on the motorway to rack up the klms.

I went and created my own tune which gave me a top speed close to 438 klm/h.

Try to not crash and keep it above 400 klm/h and you will soon have the required klms you need.

Download my tune if you need to, i have shared it, called Motorway 435 klms.

Hope that helps people :slight_smile:

No issues for me. Couple minutes up and down the motorway. Xbox One X in performance mode (60fps).

OP, in the pause menu, right bumper (RB) over then click on the Forzathon menu to check your mileage progress.

I did the Speed runs in the Playlist and a few of that PR Jump near the Festival and noticed I had completed it. I don’t know what happened to the gauge!