I have given up...

FH2 Storm Island expansion, sweet let me get it. Download complete lets play, Oh I can’t it freezes. Lets uninstall DLC and try again. Still not working, freezes as soon as i go into Storm Island. Do some research apparently not the only person with same issue so lets uninstall DLC and wait for and update to fix issue… Now go into online free roam with friends/ Horizon Solo and if I use any Forza Hub other than the Horizon Festival main one, I freeze…?! Anytime I go through a Speed Trap now it never updates new record. I have come to the forums read how multiple people have gotten there’s to work. I have done every which way of an uninstall and re-install and have no success and this has been going on since the release of Storm Island. At one of my last attempts to re-install this game it says it has an update. Hoping that this would be my fix, sadly it was not, same issues just another day. A week of hours committed to uninstalls and installs for nothing So disappointed to pay for a game/DLC that i can’t truly play or even play at all.

Have you gone in and cleared youre persitant storage or went in and cleared youre alternate mac adrees or remove youre profile from the xboxone then then put it back in ive had similar issues and called Microsoft and they walked me through problems Microsoft usaly dose t give up they will walk you through trouble shooting until its working.

Tried this morning with no luck… This issue occurred the day i downloaded Storm Island. Since then it seems as if most of the game is corrupted. It’s a Forza game issue. The only thing I have not done is delete game save data from everywhere, which I’d really not like to do, but seems like my last and final option.

If the game install data was corrupt removing your save data wouldn’t help.

  1. Try uninstalling Storm Island DLC and re-installing it. It may say “ready to play” but do not play Forza Horizon 2 at all, until the install is done. This is the biggest cause of install issues with content.
  2. Try clearing your cache and power cycling your console. Hold down the power button on the Xbox itself until it beeps and the light turns off (roughly ten seconds). Then remove the power cord from the back, count to 10 Mississippi and put it back in. Reboot.
  3. Try clearing your MAC Address settings. Go to the Settings → Network → Advanced Settings → Alternate MAC Address → Clear. This will in turn reboot your console again.
  4. Go to Games & Apps → FH2 and make sure everything is ok. Look for file sizes, make sure they are all what they should be, look for the yellow ! in a triangle - if you see this that file needs to be re-installed.
  5. Remove Forza Horizon 2 - not the game save data, just the game and any DLC content you may have loaded. Once removed, re-install. Again, do not play until installation is 100% complete regardless of what the Xbox says.
    5.5) Call Microsoft Support if you don’t feel confident doing step 6 on your own.
  6. Remove save data “FROM THIS CONSOLE ONLY”. Do not remove all your save data, remove it only from your Xbox and let it re-sync from the cloud. Make note, this may take up to two hours. Before removing your save data, make note of its file size. Then, once you start the sync you may periodically check your Games & Apps and see what your save data file size is. Once fully synced, the save data should be the same size as before you removed it and the sync banner should disappear and allow you to play FH2.

This is basically what Microsoft Support will walk you through. Try these steps, in this order, and after each step see if the game works. If not, I would call Microsoft and they will help you figure it out.

PPiDrive - I appreciate the time and effort you put into this for me.

Step one i have done countless times since issue began, so that one is a lost cause lol.
I just did steps 2 and 3 with no luck in fixing my games issues
Step 4 i have no “!” in a triangle
Step 5 I have also done a number of times, but i am going to attempt to do again right now…
Step 6 I have done once, I’m just afraid that my only fix will be to remove it from everywhere not just the console

I will let you know if I have any luck, thanks for your time.

If all fails I will call Microsoft, but not on Christmas, I can wait a day

Officially have tried everything and even just tried to install FH2 itself with none of the car packs or VIP or Storm Island and game still does not work

This game ran flawlessly until i downloaded Storm Island which has apparently corrupted the individual game itself

I’m wondering if the DLC corrupted my game save and every time the game syncs back up from cloud, if the error exists in there?

I’m unsure.

Is your actual game digital or disc?


If nothing else has worked, you may have an error on the disc itself. I’m unsure how downloading the Storm Island DLC could have caused an issue with the game itself. It would be more likely the Title Update the game needed in addition to the DLC. Since we can’t simply delete the Title Update on the Xbox One, you would have to do the long way around.

  1. To do this, uninstall the game and the DLC.
  2. Disconnect your console from the internet - no hard wire, no wireless, no internet connection what so ever.
  3. Insert the FH2 disc and let it install 100%.
  4. Connect to the internet and attempt to play the game. It will say updates are needed and give you a size, accept and wait for it to download. Then, see if the game works.
  5. If the game works, download the Storm Island DLC. It won’t have to download the patch after since it will have already done so.
  6. While installing Storm Island, DO NOT PLAY until 100% complete. Then give it a try.

If this doesn’t work, you may want to try a new disc, either through the retailer you used to purchase your game or through T10/MS directly.

I have had terrible, game breaking issues with Assassin’s Creed Unity regardless of patches, fixes, and all the likes. I was in a similar situation to yours in the end and decided to get a new disc. Through Ubisoft support I was able to return the disc in exchange for a new one (have not yet received it) which will hopefully fix the issue. [In my situation, I have my doubts but we’ll see once I get the new disc.]

I would suggest calling MS again tomorrow or the following day and try to work through to a solution. If nothing works, ask them if you can return the disc for a replacement. Turn 10 and Microsoft should have a faulty disc replacement program in place. It may result in down time for a few days but if it fixes the issues in the end, isn’t it worth it?

Have u called Microsoft i hate to see people lose their $$ if ur local i would love to have a crack at it.

ppi if there is an error on the disk it should automatically update the corrupted file via live. a replacement disk costs $20. Xbox Support the game plays off the hard drive so unless the console is telling you “please inset disk” its not the disk, the disk is only used for a drm check, not to actually play the game.

live was subject to a denial of service attack over christams so that may be the problem, his dlc/update was corrupted. google lizzard squad christmas if you want more info. they took down playstation too. wait until live is up 100% for services then try to uninstal and reinstal again. Xbox Support check that link before trying to instal or update. it was just intentional bad timing caused by jerk hackers i believe. try it again as long as live is 100% up.

I only mentioned the disc replacement because that is what was mentioned to me. Again, that was a different game, and different company, and who knows if it will even fix the issues.

True, live was down and I did not think about that when I saw this thread. It’s unfortunate OP went with delete game saves everywhere, as that may have been unnecessary. I would have held onto the game saves and tried one more install and download with XBL working.

UPDATE: so I decided to go drastic and, one again, uninstall game and dlc’s… as well as delete game save data from everywhere, not from console like I had done before…

As of right now game is running as it should, can go into different Hubs without freezing and can actually play Storm Island finally!

Still a bit disappointed that I have lost ownership to car designs up for community and paints that were in works/created decals… but at the end of the day I can actually play the game again

Will keep this posted if that all changes, thank you guys for time and effort

I hear ya, but i did all the uninstall - install prior to the attacks on xmas. The day i downloaded Storm Island this issue occurred and immediately started the process’

I have the exact same problem, and I have also pretty much given up after wasting hours reading forums and support articles. It sucks. It also sucks that the only option is to wait for Microsoft to release a patch (as far as I know)

You can always did what I did…

Delete game save from everywhere, not just from console. It’s seems the error/corruption was in the saved data