Game won't let me open telemetry, even though the control is bound

Telemetry is bound to down on the D-pad. It does allow me to scroll through the menus but just wont open the telemetry menu. I noticed a few days ago that Anna was turned back on leading me to believe the game reset the controls to default, but even after turning Anna off again it still won’t let me open telemetry. This is really frustrating to me and i appreciate any and all help, thanks in advance!

Same thing’s happening to me. D-pad right is bound to changing to the next radio station and that’s working, D-pad up opens photo mode and that works too, but D-pad down does nothing. I’m really missing the telemetry for alignment tuning!

Hey, @BigE1205, if you’re still keeping an eye on this, I just got a good response in email from the FH4 support team. Here’s what they said:

This sounds like an issue that we’re currently investigating. I’ve added your information to our investigation. I am marking this ticket as “Solved” as we do not require more information from you for our investigation and are working on a fix. We don’t need to bother you with a ton of questions or troubleshooting tips, as its being worked on by our devs already.

We will send out an announcement to the Community when we have a resolution.

Thank you for taking the time to write in on this!
Forza Support Team

Both changed?
Controller>Advanced Options Anna/Telemetry/TTS set to Telemetry
and Settings Hud and Gameplay Anna>Off