Game needs Update CPU still Needs Fixing and maybe GPU

This Game Dose’t fully use all Core Especially for a new Game I got an 4690K and it’s only using 2 Cores at 100% ??
and my GPU is only Usage is 60% and Memory is at 1,800MB and GPU TEMP is 62c and CPU is at 74c
the game Runs good but it Stutter’s a this is kinda Silly
other games run fine but this one dose not fully use my Hardware
this is not normal for a game to be running like this
My System Spec:
OS: Win 10 -64bit
RAM: 8GB (2x4GB) Dual 1600MHz
HD: WD-Blue 1TB 7200RPM
Samsung 850 EVO 250GB
CPU: i5 4690k
-3.5GHz/Turbo up to 3.9GHz
-Quad Core L3 6MB
GPU: R9 270x
-Memory 2048MB GDDR5
-Memory Clock 1400MHz
-Bus Width 256bit
-Bandwidth 179.2 GB/s
-Shaders 1280


Yep. Same here. Hoping for a big update one of these days to bring us out of beta and in to 2016, where more than 2 cores can be used! 4770k, 980Ti, 16GB DDR3, game on an SSD and it only ever uses cores 1 and 4 at 100% while the others (hyperthreads as well) just sit there twiddling there thumbs. Come on, T10, I want to see you succeed on PC! I’ve been hoping for Forza on PC since the first game as I’ve always been a PC and console gamer. I just hope FH3 doesn’t end up using this same engine. My experience with F6A has really made me super unlikely to pre order FH3 on Win10 until I see how it performs after release.

Sorry for the shameful copy and paste of my last post, but I don’t want to type it all out again. Let’s just say I got the game running like it does on X1, but in 4K.

Wow. I am blown away. So I tried out all of the affinity and thread changing stuff first and then did a few races. It only made things worse, with even more frequent stuttering and lower frame rates. Set things back to normal and got back to 60FPS lock with a stutter or hitch every 4-5 seconds. Decided to go through task manager and change the priority of the game executable to “below normal” and do a few more races. Game ran the same. Rio in daylight was playable but full of stutters, Spa in the rain was an unplayable stutter fest and so on. Decided to change the priority of the game to the lowest setting possible (low I think it was) via the task manager details menu…HOLY COW! The game runs like a dream now! Played a 6 lap race on Rio full with 16 cars and not a single stutter! Proceeded to play Brands, Spa and Yas with the same result. This is with maxed settings and 4k resolution. The only time I can get it to drop under 60FPS is on Spa in the rain and 8xMSAA, so I just turn it down to 4xMSAA and it is perfectly playable and looks the same in motion.

The last few laps of my Brands race in GT3 cars I actually forgot that I was playing on PC, something that hasn’t happened since the release of FM6:Apex. Having a full race locked at 60FPS with zero stutters, just like the X1 can do, totally got me in the zone and put a big smile on my face even though I finished 6th! No matter the level of skepticism, I would at least give this ~10 second fix a try and see if it helps you out at all. CREDIT TO BallaZ83.

TL:DR - Open game, open task manager, go to details tab, right click on forzamotorsportapex.exe, change priority to low, go back to game.

If anybody relevant from T10 sees this, my system is as follows.
ASUS Z97-A 2801 BIOS
i7 4770k @4.4GHz w/Hyperthreading enabled
EVGA 980Ti 6GB @1400/7800
16GB G.Skill 2400MHz 10CAS DDR3
Samsung 840 EVO 250GB
Xbox One controller