Forza Horizon 5 infinite loading screen

Infinite loading screen,It takes a long, long time to enter the game
Sometimes it prompts We couldn’t sign you in to Xbox Live 0x80004005
and it freezes when entering the tuning search or painting, and you have to wait for a long, long time
But No problem if you enter Horizon 4

Things I have tried to fix this that didn’t work: (in order)

  • Verify game file integrity through the Steam client
  • Re-login to Xbox, and the Microsoft Store
  • Re-install entire game and DLC
  • Run FH5 as admin
  • Alt-tab, shift-tab, alt-enter, spamming Windows key

PC Microsoft Store verison
win10:19045.3996

Same problem here

1 Like

i also have the exact issue. Do you also have the issue with infinite data syncing when booting up the game?

1 Like

i have that exact issue now, game just syncing data infinitely and I’ve tried everything :confused:

1 Like

When did that happen for you?

1 Like

Followed this procedure – https://support.forzamotorsport.net/hc/en-us/articles/360005306553-I-ve-lost-all-my-progress-what-do-I-do to reset my progress and start fresh, but it seems as if I can’t get past syncing data … for ages!!!

  1. Make sure your PC Offline Permissions is set to ON
  • Open the Microsoft store.
  • Click on your profile image and then click settings.
  • Make sure your Offline Permissions is set to ON
  1. Start the game, wait for the start screen.
  • Start screen is the first screen that has the menu options for start game, accessibility, and/or option settings.
  1. Disconnect your PC from the internet.
  2. Go to your Windows 10 Settings → Storage → Apps & games -->Forza -->Advanced Options -->Select the “Reset” button.
  3. Start playing for a few minutes to create a new local save
  4. Connect back to the internet.
  • If you are prompted to pick a save, you only need to select “LOCAL” for this time. Moving forward, you will want to select “Cloud.”

All I did in the game afresh was the intro and the first showcase and exited the game.

I have been waiting now for “Syncing Data …” to finish after 30 minutes after selecting my local save (1 MB & today’s date) and not the cloud (445 MB & yesterday’s date) and it says 0%

What is it doing??? It is really slow. I assume it is saving my local to the cloud, but it is really really slow for only 1 MB file!!! – and I have 1 Gbps Internet too.

UPDATE 1: It finally says 1% 2% 3% 4% 5% 6% 7% 8% 9% took 15 minutes to this far

UPDATE 2: Speeding up a bit now 10% 11% 12% 13% 14% 15% 16% 17% 18% 19% 7 minutes for this

UPDATE 3: Hope is stays at this speed 20% 25% 30% 35% 40% 45% nearly half way about 10 minutes

UPDATE 4: Patience is the key 50% 60% 70% 80% 90% I am hoping it looks good

UPDATE 5: Nearly there!!! 95% then back to Syncing data… oh boy!!! hope it loads up a fresh game!

Update 6: Still stuck after another 30 minutes

Update 7: An hour after reaching 95% and still not running and stopped showing the % and just showed “Syncing data…” again.

Update 8: Do I give up trying to play FH5 now? Because it sat on “Syncing data…” again for at least a couple of hours.

1 Like

The Support rep told me to do this

Windows>Settings>Applications>title>Advanced Options>Reset – DONE

Type WSReset.exe, and click/tap on OK – DONE

You can try deleting the \AppData\Local\Packages\Microsoft.624F8B84B80_8wekyb3d8bbwe\SystemAppData\wgs – DONE

Disconnect PC from the Network – DONE

Go to your Windows 10 Settings --> Storage --> Apps & games -->Forza -->Advanced Options -->Select the "Reset" button. - DONE

Start playing for a few minutes to create a new local save - DONE

Connect back to the internet. – DONE

I then exited the game.

Screenshot attached shows status, whereby I had completed introduction (all the jumping out of the plane, in the Bronco, Corvette and Porsche) and was ready to do the 1st showcase with the motorcycles.

And asked the support rep “Now what?” and am still waiting for a response, before opening the game again.

I have not yet restarted the game, whereby I have to select between my local or my cloud. Last time I did this is above happened.

1 Like

What’s funny. That loading screen. Doesn’t even load you into the game. It’s literally a fake loading screen

1 Like

I solved the problem using this method I hope it helps
Original post:Reddit - Dive into anything

Thanks to a wonderful member u/SnooBunnies2012 there is now a solution that worked perfectly f or me?

opted out of xbox pc insider then uninstalled it. Then uninstalled game bar using terminal administrator copy this in

Get-AppxPackage -AllUsers -PackageTypeFilter Bundle -Name "*Microsoft.XboxGamingOverlay*" | Remove-AppxPackage -AllUsers

then i uninstalled

Xbox App

Gaming Services

Xbox Live

Then restarted computer and then went back to store reinstall xbox app run in and then let it update the stuff needed after that in store type in game bar and install it. After that go back into terminal administrator and type in each one separate and enter Type in the following commands. Ensure that you press Enter after entering each command:

sfc /scanfile=c:\windows\system32\ieframe.dll

sfc /verifyfile=c:\windows\system32\ieframe.dll

sfc /scannow

once done restart computer and load game and should then all work for you. Hope This helps

If this fix works for you, please make sure to upvote their comment below.

1 Like

I Also contacted the forza Support. The support provided me with the following solution that worked for me:

Sign out of the Xbox App, Xbox Game Bar app, and Microsoft Store app.
Please perform the app reset for each of the Xbox apps:
    Windows > Settings > Applications > Forza Horizon 5 > Advanced Options > Reset

    Windows > Settings > Applications > Xbox App > Advanced Options > Reset

    Windows > Settings > Applications > Xbox Game Bar > Advanced Options > Reset

    Windows > Settings > Applications > Microsoft Store > Advanced Options > Reset

    Windows > Settings > Applications > Gaming Services > Advanced Options > Reset

Reinstall the Gaming Services app on your Windows 10/11 device:
    Select the Search icon on the taskbar, type powershell, right-click on Windows PowerShell, and then select Run as administrator.

    In Windows PowerShell, type the following command and press Enter:
    get-appxpackage Microsoft.GamingServices | remove-AppxPackage -allusers

    In the same window, type the following command and press Enter:
    start ms-windows-store://pdp/?productid=9MWPM2CQNLHN
    Install the app on that page and select Yes when you receive the User Account Control (UAC) prompt. 

Once these steps are completed, please launch the game again and test if it lets you sign into your account or if the same error message appears.

its similar to the solution that @stevenwu1992 provided but little bit different. The more solution the better the chance to fix it.

Hopefully this will work for you!

1 Like