FM7 doesn't recognize Fanatec CSL elite [PC]

Hey everyone,

I’ve been looking for a solution to this problem for weeks but haven’t found anything.
I have a fanatec CSL elite on PC which works fine in Horizon 4 without having to configure anything, just plug and play. However, FM7 doesn’t recognize it at all, I tried putting the wheelbase in different modes but it didn’t work.

I can’t be the only one with this problem, hope someone here can help!

Have you tried creating a custom wheel profile in the Options area or deleting any old ones that may have been created already?

Yes I have tried creating a custom profile and manually binding each function and that sort of works except that I can’t control any of the menu’s, the FFB doesn’t work, the steering lock is WAY off, there’s is a GIANT deadzone in the center which I can’t get rid of etc etc etc.

i have no FFB anymore in my clubsport V2 base since the latest windows update

@Juulus - what deadzone settngs do you have under your profile; if I remember correctly, you need to use a keyboard to navigate menus; the wheel buttons only seem to work correctly when actually driving.

I have a CSL elite xbox on PC and the same problem.
No FFB in PC mode and FFB all wrong and uplayable in xbox mode on PC.
This has been going on for months, it needs to be fixed.