FH3 - No longer working, instant crash when trying to load the game. PC


Was away from home for 3 days… Come back to play some FH3 on my rig and now it just crashes without even allowing me to press enter to start the game.

Have tried re installing the game which was a ball ache and still the same result… Crash

I don’t have shi*** hardware so that is not the problem either.
have tried installing some trash app in the ms store (as it used to fix crash issues for me on FH3) but now that doesn’t work either.

Getting seriously fed up with the amount of problems i keep having with this game… Funny how they have just bought Zenimax etc but they can’t even fix their own games yet alone games like Bethesda’s fallout. Would love to see them make a fallout game.

Error log down below.

Faulting application name: forza_x64_release_final.exe, version:, time stamp: 0x5b171431

Faulting module name: TargetHardwareProfiler.dll, version:, time stamp: 0x57a882c5

Exception code: 0xc0000005

Fault offset: 0x000000000001c826

Faulting process ID: 0x194

Faulting application start time: 0x01d695ec73efe5d4

Faulting application path: C:\Program Files\WindowsApps\Microsoft.OpusPG_1.0.125.2_x64__8wekyb3d8bbwe\forza_x64_release_final.exe

Faulting module path: C:\Program Files\WindowsApps\Microsoft.OpusPG_1.0.125.2_x64__8wekyb3d8bbwe\TargetHardwareProfiler.dll

Report ID: de4a8193-6643-40bf-aaa5-a471273279be

Faulting package full name: Microsoft.OpusPG_1.0.125.2_x64__8wekyb3d8bbwe

Faulting package-relative application ID: OpusReleaseFinal

Any help is appreciated. I just wanna rage my V10 E92 M3… Looks like that’s too much to ask for.


I also have this error. There is no solution. Telephone customer service shook off.
FH4 works flawlessly.

I disable my cpu graphics in device manager and it fixed the game

i do but still not worked