FH3 Crashes Instantly!??!?

Hello forum,

Today I got on my computer and turned it on wanting to have some fun on FH3. Once my PC started up and I clicked on the application it opens up to the gray screen with the pic of the Lambo and the FH3 logo and then 2 seconds later it crashes back to my desktop.

The only thing I’ve changed recently was updating my NVidia driver yesterday evening, but other than that nothing to drastic.

Is this a driver issue or a game issue? Any help would be much appreciated!

Thanks for your time,

Zach H.

Im having this same issue with both FH3 and F7, but it seems to be random, yesterday they worked, today they dont


See #23 and try.

I bought a 1957 Plymouth Fury. Game crashed.


I was also having the issue where FH3 would only load the splash screen and quit. This all started happening after updating to the Windows 10 Creators Update.

Originally I was able to fix it by reinstalling FH3, but that’s a long and tedious process. Then read about others just installing some random free app to re-register MS Store app to the PC. So I tried this method and it worked! But you don’t have to download/install the entire app. Just initiate the install, and once the download starts, go ahead and cancel it. Wallah, FH3 works again!

I believe this issue happens to PCs that are logged on using Local Accounts instead of MS Accounts; I refuse to tie my PC to MS Account in order to log on to a PC. I think that after the Windows 10 Creators Update, there are some issues with registration of MS Store to Local Accounts. When FH3 does not start, the error log states that the PC can’t get access to the exe file to launch FH3.

And when manually trying to access the Windows Apps directory, you get permission restrictions. If you look at the folders permission rights, there is an unknown object container. Therefore, when you initiate a download from the MS Store, I believe this process re-registers the systems account to get access to the Windows Apps directory which then re-enables access to the locked directory that your apps are installed on.

Hi dudes,
Today I wanted to play Horizon 3 and when the game started everything was fine. After 30 seconds the game just crashed. I tried to restart the game and my Xbox one s but the problem is the same!
Help me, please!

I spent around 5 hours trying to fix it

I even uninstalled everything and re installed again

I did all options on the net available …

By now its clear problem is from xbox application.


Hi all I’m currently having issues also with horizon 3 crashing to dashboard all privacy settings are up to date and set to adult still has not helped game loads to start menu press A and it crashes never had this issue before plz help.

FH3 crashing during startup is a completely different issue, and it gets solved by installing any app from the MS Store; I have this issue, even when my Win10 is using the MS account (not Local). However, the new crash from yesterday in Win10 is causing a kernelbase.dll issue; but it is also crashing in XboxOne, and many people seems to be reporting same crash. I hope they solve this soon.

Am having this same issue on Xbox one x getting to game loading page and it crashes after a few seconds

Hi all,

We are aware of these issues and working on getting things sorted. Thanks for your patience in the meantime.


Thank you! I got the same problem with my Xbox One S, too. I contacted with Xbox support, and I got the link to this thread. However, FM7 works fine for me. So, fingers crossed.

So this was posted well over 3 hours ago, and the game will still not start up. I get that you’re working on it - but why isn’t this showing up on the xbox live service status page?


No sign of anything forza-related not working. If you were going to be fixed in 10 minutes, I get it, but 3 hours deserves to be reported, no?


I agree, I ended up restoring my PC, reinstalling Drivers etc, thinking that is was an issue with my PC, a simple official report that this is a game issue could help many people.


Been having this issue for 12 hrs now

I did everything imaginable

Restart pc
Uninstall app + re install + reset
Uninstall game + uninstall DLC’s + re install

And pretty much all things i found on the net

Xbox app keeps crashing on its own…

FH3 still crashing on both WIN10 and XBOXONE since yesterday. I hope this can be resolved soon, and our saved game files are not corrupt.