Failed to find game session on Xbox

I tried to fix this issue doin a lot of things but I still couldn’t fix this issue. everywhere I see people mentioning this issue they don’t get any respondents or won’t even continue helping them.
Is anyone getting this issue? please help me if you got it resolved.
My NAT is open and everytime I test the multiplayer connection it says that everything is good.

The problem is, people with issues generally aren’t very forthcoming with what they’ve actually tried. They seldom give specifics to even what they are playing on(Xbox/PC).

Just saying tried lots or everything, that just doesn’t sound very inviting for someone to offer a suggestion. And more often than not, when a suggestion is given, not a peep from the OP as to wether it helped or not.

I, just like you, am a consumer. The moderator just doesn’t really offer help, but polices the forums. Actual support can be reached @

If you gave more detail about what you tried, someone might offer something up.

Okay, at first my upnp was not successful, so I used port forwarding. And then it said that I have double NAT, so I connected an ethernet to my Xbox. And then it was perfect, it was open and not any single problem with my internet connection or anything. now everytime I try to join a lobby, it says intializing matchmaking request, please wait, creating matchmaking request, and then it says please wait for over a minute until it say failed to find game session. And I can’t seem to find any help with my issue which is I have an open NAT and all of my services are available.