Blizzard Mountain not working [X1]

nullSo, downloaded the expansion pass and was looking forward to this today and just about to travel to blizzard mountain and no apprently I don’t have it? Any support around for this

Keep getting an error saying “failed to download required marketplace data. Please try again later.”



I’ve got the cars (apart form the barnfind and the Focus RSRX) and when I go to the island marker in the airport I get redirected to the marketplace, followed by an error message. If I go to the marketplace in game it tells me I have installed the content.

I’ve tried a restart of the game, the console, and a hard reset to no avail. Anyone else?



Same. MARKETPLACE ERROR Failed to download the required marketplace data. Please try again later.

1 Like

The update release is a ducking mess, that’s what.

Late and unintuitive. Try resetting again

Good luck, mine is still downloading

Just bought the expansion pass and can’t install blizzard mountain, I just wanna play in the snow :frowning: lol

1 Like

Same here. Got me bewildered and just a bit peeved.

Thank you! You sir are a god! Downloading as we speak.

In the XB Store under Forza Horizon 3 Expansion Pass it says “This product is installed”. Nothing more. There is no way to install it again.

1 Like

Go to the xbox store then search horizon 3 when you get there filter the search for add ons only then should show up blizzard mountain by itself click on that then if you have the expansion pass it should say install then go to your my games and apps and wait for the 3.66 gb file to install all done should be good from there

Go to manage game and install blizzard mountain from the ready to install list.

1 Like

I fixed it!!!

Go to Games and Apps
Go to Forza Horizon 3 and hit start button (or whatever they call it now) and click “Manage Game”
scroll down to “Ready to Install”
Then click Install All.

My install queue is showing blizzard mountain installing as I type this…

It isn’t on the ready to install list because it says “already installed”???

It isn’t on the main “Ready to install” list.

Go to FH3, click menu button and click “manage game”.

Its on the individual FH3 “ready to install” menu.


Thx. I was figuring this out as you posted.

Odd thing is that I had 4 items to “install”. Warthog, Logitech G Car Pack, Blizzard Mountain and something else. All the other stuff I have been playing with since they dropped.


I bought the expansion pass a few weeks ago. It tells me it installed. When I try to get into Blizzard mountain it asks me to buy? I already bought! I hit purchase anyway and it tells me MARKETPLACE ERROR???

Answers please!

Did you reset your Xbox and install the SECOND update?

Go to manage game and install it from there.

1 Like

I’m getting the same message… came here to find out why

Try type Blizzard in store