[ANSWERED] FH4 doesn't work on PC/Win 10

What a disappointing experience. I used to play on XBox (had 360/OG1/1S/1X), but have since gotten out of console and play mostly on PC. Most of the stuff I play on PC is not related to XBL (Destiny 2, Division 2, F1 2018, etc.), but I’ve been eyeing a sale on FH4 since I haven’t played it (sold my consoles before it came out), and was looking forward to playing it at high frame rates on my 1440p/144Hz monitor. So when I saw the current sale, I jumped on it and got the Ultimate Edition (I’m a long time series fan and customer, pre-ordered FM7 Ultimate for example).

The game will not start no matter what. I have tried all the fixes in all of the threads I could find (at least a few with [SOLVED] and/or [ANSWERED], at least 2 on here) to no avail. A lot of people mention MSI Afterburner, I don’t use this. I’ve tried closing all other programs including some system services, re-installing (what’s 70 GB here, 70 GB there, bandwidth and time be damned), switching to the windows admin account, nothing works.

My setup is pretty standard:
Gigabyte Z370 Gaming 7
i7-8700K
32GB PC3200 RAM
1TB SSD
SAPPHIRE NITRO+ VEGA 64 8GB
Win 10 Pro 64 Bit with all updates as of today installed
AMD Adrenalin 2019 Edition 19.4.1 Driver (current stable as of today)

This PC is rock stable and plays Destiny 2 on Max settings at 2560x1440 averaging 100-144 fps the entire time.

FH4 makes it to the windowed splash screen (not full screen) and then waits there, sometimes 10 seconds, sometimes for what feels like upwards of a minute (and sometimes it feels like >1m), then that window just goes away. Game never starts.

Any hope for me?

Have you done the windows store cache reset?
Have you made sure you have full permissions for the folder the game is installed in. You might be able to install but still not have the required permissions to run it. It’s a weird bug but it’s part of the way windows allocates file and folder permissions and sometimes it screws up spectacularly!

1 Like

Yes, I’ve tried doing the extreme

I also tried wsreset.exe. Nothing has worked.

It's unbelievable how poorly managed the installs are, I've seen stuff that's nowhere near what a company like Microsoft, who's been writing Operating Systems professionally for decades, should be doing: halfway aborted installs, computer will go to sleep while there's an install download in progress then pretend it's fully installed (it's not, only 40% has been downloaded), I try "uninstall" and it says it did it but all the files are still there, after a reboot the entry shows again but it says it's only 8kB or 16kB, trying to reinstall it gets stuck perpetually on "Acquiring license"... it's a nightmare and it's shameful. None of this should be happening, including the messed up permissions. Instead of using the Windows platform to their advantage to get a leg up on the competition (Sony doesn't have an OS), they've completely crapped on the PC side of Play Anywhere. It's a shame this game is exclusive to XBox (I would add slash (/) PC, but it doesn't work on PC).
1 Like

It works fine on PC (most of the time). I had the same problem you’re describing with H3 at first. It was fixed. One thing you can try is going into the windows settings, find the H4 app then reset it. that works for some people. Other than that if you want help you need to go to the official support page (there’s a pin post about how to submit a problem and where to go in these forums).

Yeah the installs are poor. I told them during the test phase of windows 10 this was a problem and i and others were ignored. It’s because they had a system in place which was overseen by MS Office staff, and was only for that. When games were thrown in, it didn’t work but they already had a sizeable investment in it so carried on regardless. Now WE have to deal with all the problems that causes!

1 Like

None of the stuff I’ve read fixes this, I’ve reinstalled a total of 5 times now, resets, everything. Here’s what I am seeing in the Event Viewer:

SunriseBaseGame is definitely FH4, Sunrise is its code name. I haven’t been on Windows in a bit, anyone have a clue as to that the source for this “Activation” fail could be? The above is an error, before it is an informational message:

Do you use MacType? If so, disable it before starting the game. You can also update MacType and add ForzaHorizon.exe to mactype.ini file in the exclusions section.

I use MacType and have had to disable it to get the game to run. Could you possibly tell me in layman’s terms how to exclude FH4?

I looked in mactype.ini, there is no exclusions section so I added this:

[ExcludeSub] (I also tried [Exclusions] and [Exclude] )
ForzaHorizon4.exe

I restarted MacType but the game still won’t run (unless I disable MacType fully). It would be nice to get the exclusion working if possible.

edit - I also added it to every applicable section I could think of, in the default,ini file which already included exclude sections with other EXEs listed. That didn’t work either.

Where are you installing it?

nope. but now I’m gonna look into it :slight_smile: if I ever get FH4 working, first lol

c:, a 1TB SSD on which Win10 is installed.

Few things to try, did you check your Permissions? Not the game it is the way the windows store works and the problems it has.

https://www.maketecheasier.com/access-windowsapps-folder-windows-10/

https://www.google.com/search?nfpr=1&q=windows+apps+open+then+close&spell=1&sa=X&ved=0ahUKEwiy-NPNgYLdAhWvUt8KHcIKAc4QBQgkKAA&biw=1920&bih=918

Same exact problem for me. Installed in default location on SSD. I just uninstalled it until there’s an update to this issue.

My dudes, I figured it out! This computer is a dual boot with another operating system which stores system time in UTC (Windows uses local time by default), and the system time when booting in Win10 was UTC instead of Pacific US. On a whim I decided to set the time automatically, and that fixed it! I’m religiously taking ownership of everything in c:\Program Files\WindowsApps\ now just for good measure, but I am finally able to play this game :slight_smile:

1 Like

Good to know and good that you came back to tell people how you fixed your problem. Usually people fix it and never come back!
Taking ownership of files is one of the most important things you can do if windows store is playing up.

For sure, I came here for help and you guys really made me feel at home and welcomed, so def want to pay it forward!

Good to know, I only really use Win for gaming, but games are likely some of the larger and more complex programs installed thru WS. That Take Ownership registry fix which adds it to the context menu (posted by leetorts – thx!) is a godsend!

Thanks again to all who helped. I’m now rockin’ FH4 in 2560x1440 on Ultra, holding at a steady 100+ fps! :sunglasses:

1 Like

This any use to you FullNietzsche?

I found that before actually when I googled, it only tells us that the exclude function wasn’t working in 2016 and apparently still isn’t in 2019 (I’m using the latest version).

But the above poster says it works, so I’d be interested to get the exact instructions.

(MacType is great but it could be massively improved in terms of user-friendliness, it’s incredibly convoluted and complex to use for such a simple little program. Well I mean, it works easily enough out of the box but if you need to change anything, then it gets silly.)

I’m glad to see the OP got their game working.

2 Likes