PC - Random/huge drops in frame rate during races

Right here’s my two cents! I run the game at ultra, 60fps lock, i5 2500k, GTX970, 8GB ram, during pretty much every race I try everything runs great (60fps)but I then get random drops to 2-3fps, only resuming normal operation following pausing the game, alt tabbing or moving the mouse to the top of the screen, or a random mixture of all 3 (I haven’t found a way which works 100% of the time) anyone else having these hitches, stutters? Help please, all I wanna do is play!!

nvidia problem, already tested by many ppl. probably something to do with that the game needs to run on 4k 60fps on a weak amd chip, so it got way more dev love for amd chips than nvidia… we have to wait for nvidia to fix the code/bugs over the driver or for turn 10/microsoft to fix them over the game… my guess, nvidia has to do it…

Interesting, what you playing on?

  1. Turn off “Game Mode” - “Game DVR” - “Game Bar” in Windows Game Settings.

  2. In Nvidia Control Panel - Power Management Mode - Prefer Maximum Performance
    In Windows Control Panel - Power Options - High Performance Plan

  3. Do not run any Overclocking / monitoring / video capture software.

Also, i notice when the AI crash into eachother, or something goes weird with AI, the game starts dropping FPS also.

1 Like

After several hours i have to say (again) this few “Tweaks” cured almost all my Problems with Stuttering; I have a 1080 and can play with 4k all on Ultra 4x MSAA (also 8 but thats literally the same dunno why) and even 120% Res Scale up :smiley: So yeah, if it runs it runs very very well.

thanks,fixed it for me


well i was wrong, fixed it for 5 races… back to stuttering…
wierd thing is running the benchmark doesnt stutter in any way.

Yeah I’ve done all those ‘fixes’ even tried running on dynamic and locked at 30fps, still happens, I’ve tried moving the install to another drive, see if that helps…

I’m in the same boat as you guys. Here’s all I did so far to play this game properly… After the download nightmare (3 days of store epic fails, ending with download manager and windows powershell command)

-moved the game from my “old” samsung ssd 250gb to my more recent 1t seagate hdd.
-Turned off my 4.5ghz oc of my cpu to get back to normal (i7 4790k)
-nvidia control pannel (gtx 1080 g1 gaming Gygabite) : High performance (default setting for my games anyway) + shadow cache Deactivated (like some People suggested for fh3)
-windows all game mode options off
-windows defender off
-all non critical .exe killed
-for forza.exe : priority to High (real time crash my game) + clicking no cores then all cores in the affinity menu (I remember this worked with need for speed hot pursuit)

After all this I can play the game almost decently (30 fps in the menus, then around 60 fps ingame, with a small taste of micro stutters/coughs at some points) … If only I’m not messing with the ingame video settings : obliged to stay in dynamic (ultra at least) for everything (with 3840 x 2160 upscale)
If I try to tweak something, like locking to 60 vsync or to the contrary unlocking my fps, it’s ending in freezings/micro stutters feist (samsung 1080p 60hz screen).
Must say too I didn’t check my cpu or gpu usage (can’t confirm the cpu core 0 thing although highly suspected), temps in any case didn’t exceed 55 for the gpu and 45 for my cpu. When I tried to lock my fps to 60 + vsync my gpu started to roar a lot more though. But as it was hopeless I quickly get back to dynamic.
I’m a bit lost with this strange behaviour, looks like the game telling me don’t tweak my settings and just drive, otherwise I’ll stutter you to death.
Just hope nvidia or t10 will improve our experience in the next few days/months (hopefully not 6 like fh3).

I7 4790k
Gygabite g1 gaming 1080
16gb ram

Yeah i have had the same problem…
my pc: ryzen1700x @3.92Ghz
2x Asus strix 1080 SLI
16Gb ddr4 Ram @ 2100+ MHz
Drives are all SSD and 1 M.2 OS Drive.
Asus G-Sync 1440p monitor at 144Hz

So why do they release a game that run this bad paid alot of Money to play the 29 pre launch and i get a game that runs this bad, not looking good tbh, and the Controls for Wheels is a pain too fix on PC, gave up so iam just playing on xBone instead until the fix the things…

Experienced stuttering either.
1st time stuttering I disabled the first core for Forza. Enabling it again cured it.
2nd time stuttering was when I enabled Windows Game mode. Disabling it cured it again.

Except the 2 cases above it runs smooth as silk, even in 6K (6020 x 1080)

Glad it’s running smooth as silk now on your rig RustlessBean495 ; and thanks for the cpu core 0 trick; I’m doing it now before each race.
Changed a bit my video settings today:
Still 3840 x 2160 upscale (1080p screen)
60fps vsync
Everything on ultra except msaa and anisotropic (dynamic settings)
Definitely not smooth as silk but playable. Must add I’m playing it almost non stop except for sleeping since launch, that is to say a bunch of hours now spent on the tracks. Which means plenty of times to be plagued with these weird stutters/frame rate jumps at any moment.
Starting to think my old gen cpu don’t like cpu core 0 Hammering that much.
Would really like to know the detailed specs of T10 rigs used for beta testing, in order to not fall into this forza horizon 3 nightmare a second time.

I7 4790k stock clock
Gygabite 1080 g1 gaming
16gb ram ddr3