Lost 1 million credits.

With only 20 minutes left on the special car dealer, I went to purchase the Lamborghini Reventon. Circle spins for a few seconds and then says “cannot complete purchase, try again later… Blah blah blah”. Ok, now I wait a couple minutes and I only have 18,000 in credits and no Lambo. What the heck?!?

Try a hard reset of your Xbox then load the game up again. Hopefully that will resolve it for you.

Hard reset = shutdown and disconnect power for say 30 - 60 seconds. Then re-boot.

Tried that as well as a system cache clearing and no luck. I still only have 18,000 credits, no Lambo in my garage, and it is still available for purchase in auction house.

AH or speciality dealer?

To be fair if it’s an AH thing have you tried retrieving your credits if someone outbid you at last second.

If it’s speciality dealer and you have attempted to purchase, it’s failed and you’ve already jumped through the usual hoops to try and resolve it. Might be worth asking a mod to move this to the technical support area, see if they can see anything there or help you out.

Good luck


Sorry, I meant specialty dealer

Thanks for the advice man, I’ll look into having that done.