FM7 Not Working

Hi. Today, the August update for Forza Motorsport came out as you all know. I updated my game with success and tried loading up the game but it would freeze on the loading screen. I had this happen with Rocket League and for that, I just deleted the game and redownloaded it, and it worked. I tried to do the same for FM7, and now, the game won’t even run and it goes to a black screen and returns me to the home menu.

What should I do?

If you’re playing on PC I’d make sure Windows 10 is up to date.

1 Like

I would but I’m on xbox one

Hard reset your Xbox, don’t just restart it. pull out the power cable and internet cable after hard resetting. Possibly reset your router too. PC players should always restart after a new install also.

1 Like

This does not work.

I have the same problem. i’m reeinstalling the whole game now, but because of my crappy internet conection mine is not done before tonight in my timesone.
I will update the situation when i get to try the game out later. I have a bad feeling reeinstall will not work.
There is another guy who have posted the same thing here in the support sectrion but he/her is on PC. (besides from my post from yesterday)

Reset your Xbox with the Keep games and Apps options and if that fails move all but the Forza Game to a external Hard drive if you have one and then unplug the drive and do a factory reset instructions are on the Xbox web site as it sounds like you Xbox may have gotten a bad or not complete update as more than 1 game was affected when up dating.

Try restarting and fully powercycling your console
As you should try before complaining on here

Wait for a patch, my game has had over a 50% CTD rate so I gave up. Probably also why the online hoppers were practically empty this afternoon.

If on xbone try doing a full power cycle of your console even pulling out the power cable from the wall

reeinstalling the game worked for me on Xbox one. but it left out the wisefab. everything else in the New update i got, but not steering angle as an option in Upgrade menu.

Edit: Never mind, i found it. everything works after reinstalling the game.

I’ve been without F7 since the update. I did a reset, hard reset, pulled the plugs, uninstalled, reinstalled, and still nothing…

Same here, I did a reset, hard reset, uninstalled, reinstalled, pulled plugs and still nothing since August