Thrustmaster TMX not recognised (PC Gamepads version)

I got a thrustmaster TMX the other day and have been cycling through my racing/driving games with ease. So far they’ve all been working, so I didn’t even worry about FH4 because I “knew” it would be most likely to work. So I plug the wheel in, turn on my PC, load up FH4 and go into settings. There’s not even a “Wheel” option in the controls menu.

I’ve reinstalled drivers, updated firmware, removed any software that I thought might conflict, but still nothing.

Is this a known thing and I didn’t read some fine print somewhere or should the TMX work with FH4bon PC? Any more suggestions beyond formatting the PC. I know I can always try that, but would rather notb until absolutely necessary.


All my other Thrustmaster hardware has drivers that you download. FH4 does have wheel settings, but they probably aren’t going to help you.

TMX works with PC version of FH4, are you on the Microsoft Store version or the Steam version of the game. You can go into the Thrustmaster software and see the wheel and play with its settings, correct?
You see the various demo modes and the wheel responds, moves around, shakes, etc? Then launch FH4…what happens next.

Even if I am not using my wheel (on my xbox) I see the option for wheel settings in the Settings/Controls menu…and I’ve used the wheel on the PC version as well, it was seamless.

Suggestion: Try using any-other USB port…preferably one that is USB 2.0 and not USB 3.0…most motherboards or older cases might have an older, slower USB port on them for compatibility, sometimes the motherboard USB slots for Keyboard and Mouse are the slowest of the bunch. Try this.

First off, thanks for the replies.
To answer the questions:

  • This is the Windows Store (GamePass) version of FH4

  • I see the various demo modes, the wheel shakes, etc…

  • if I do this before opening FH, there is no difference

  • I’ve tried every USB port on the PC

  • TMX Drivers are installed and up to date

  • TMX firmware is latest

  • there is no “Wheel” tab in FH4 for me on PC, at all.

okay, new revelation. I uninstalled everything even remotely controller related from the control panel, from drivers, device manager (even teh hidden ones). I rebooted, plugged in the TMX with no drivers installed, Windows picked it up and the little “Xbox” light on the wheel lit up. So I opened Forza and tried again and suddenly there was a “Wheel” tab in the controls settings. However, all the assignments were blank and I couldn’t even click on them to assign. So, I re-installed the official TMX drivers, rebooted, started FH4 and bam, the “Wheel” tab was gone again.

So it seems that for whatever reason, when the TMX drivers are installed, it breaks something in Forza.

Any more ideas? I was thinking I could resort to using EmuWheel for Forza, but that’s such a pain. Again, last resort.