[PC] CRASH - game crashes 2 seconds after start [PC]

Same here. No MSI Afterburner, RivaTuner etc. Updated Windows and tried everything else on the recommended fixes page. Still just the FH4 splash screen and nothing. How did this carry over from FH3??

i try: update nvidia drivers (in case you have a nvidia card), fresh install (no pause download or anything), close all OSD programs that interact with the game (icue…msi…evga…gigabyte…asus…include FPS counter), install a store app (ej: whatssap or any app) and works, you can activate programs like msi afterburner after loading map. :confused:

“It might be a program similar to MSI Afterburner!”

Take my word for it, I’ve tried everything, I got ASUS GPU Tweak and every “overlay” program I got is turned of, I have been trying literally everything!! Nothing works, this is not my PC’s fault either, latest windows, latest drivers, i7 8700K at 5ghz, 32GB of ram and a 1080TI. Come and tell me that my PC can’t handle this, please I dare you…

I don’t even have any of the programs people are talking about installed. Latest Windows update and all drivers up to date. There’s no reason the game shouldn’t run. At this point, this is something that’s going to require a patch and that patch better come before October 2nd.

I had the same issue with Horizon 3. Did you try just download some random app from Microsoft Store? It’s been helping me when I had these problem

I checked the event viewer after running and in the Windows Logs under system, I’m getting:

Unable to start a DCOM Server: Microsoft.SunriseBaseGame_1.187.929.2_x64__8wekyb3d8bbwe!SunriseReleaseFinal as Unavailable/Unavailable. The error:

Not sure if that’s any help?

1 Like

Are the devs working on it? Is feedback possible?


Yeah had this problem since yesterday now, tried absolutely everything and no luck. I had this problem with Gears of War 4 long ago too but then it launched by installing some random app on the window store, didn’t work with this game.

Tried absolutely everything as well and no luck. I had this problem with Gears of War 4 long ago too but then it launched by installing some random app on the windows store, didn’t work with this game.

For those of you that have identified the issue as MSI Afterburner / RivaTuner Statistic Server, you don’t need to close or uninstall any program and you can temporarily fix this yourselves.

Just open RTSS, and on the bottom of the profile list click on “Add”. You won’t be able to find the correct exe in any folder, but you can just type it in the text box that appears, and click “Open”.

The name you want to enter as a profile is “ForzaHorizon4.exe”

Once you’ve added the profile, just select it and on the right, click on “Application detection level → NONE”

You will obviously not be able to open the overlay in this specific game, but you can in any other game, and any Afterburner settings (overclock, custom fan speed) will still work because you can leave everything open as always.

Fixed my issue and have been able to play without any problem since.


EVGA Precision X is also causing the game not to launch/to crash. Bummer since I always use the program.
Weird thing is this hasn’t happened with the demo and I was able to have it open when the game first launched.

Hey guys, i managed to get it working i guess lets see if it will work after some play time.

I think one of those two thinks worked for me:

1.) I started the xbox app in Windows and started it from there. Not the Microsoft Store.
2.) I turned off the service called “MacType” its allowing me to have a smoother font. So check for any services that u may have installed urself.

Hope this helps someone.

I’m still getting this same behavior, i try to open, I get the splash screen and it closes seconds after. Event viewer also gives me the Exception code: 0xc0000005. The weird thing is that i’ve played the game when it released to download. I got to the open world and then it crashed and never opened again. No steps on that page helped me, i’ve tried them all a million times (and also reinstalling). This expection code seems to be pretty common from what i’ve seen on forums, so are we ever going to get a response? Are the devs aware? Are we getting a fix or… ?

1 Like

I am suffering from the same problem.
Why do not you respond promptly why development has been reported so much?
I think that it has not been thoroughly tested.