Game closes shortly after starting...

Well, here I am again, I couldn’t get Apex to run, and I figured that by the time Forza 7 comes out the odd problems will be solved…but I get the exact same problem as I had for Forza 6: Apex. The game launches, and right when the Turn 10 logo should display the game just closes…no error messages or anything. With Apex I uninstalled / reinstalled many times, tried different drives, new / old drivers, etc etc. It looked like the games use Bink video, which I suppose is being used to playback the logo, and I made sure I have the codex installed…but it didn’t work, and now I’m getting the exact same issue with F7 demo. Every other game works perfectly, DXdiag comes back with no problems, Win10 64 creators update, AMD r9 290x 17.9.2 drivers, 8gb ram. I can only think to uninstall any video codecs I have installed and go from there?? If anyone has any ideas…

You need to take a look in your “Event Log” to see what might cause the crash.

Right click start button “Run” and type “Eventvwr.msc” (press enter) … then on the left side look at “Windows Logs” → “Application” or “System” . you should see Forza7.exe (or whatever the exe file is called) in there somewhere.
If FM7 is in there, click on it and look below at the “Faulting module” or a “Exception code”.

Here’s what the event viewer shows:

Faulting application name: ForzaMotorsport7.exe, version:, time stamp: 0x59b869af
Faulting module name: ForzaMotorsport7.exe, version:, time stamp: 0x59b869af
Exception code: 0xc000001d
Fault offset: 0x0000000000e98260
Faulting process id: 0x2e34
Faulting application start time: 0x01d334e80a3f0681
Faulting application path: C:\Program Files\WindowsApps\Microsoft.ForzaMotorsport7Demo_1.105.697.2_x64__8wekyb3d8bbwe\ForzaMotorsport7.exe
Faulting module path: C:\Program Files\WindowsApps\Microsoft.ForzaMotorsport7Demo_1.105.697.2_x64__8wekyb3d8bbwe\ForzaMotorsport7.exe
Report Id: c5be1568-54e5-4d11-9300-20d14bd12513
Faulting package full name: Microsoft.ForzaMotorsport7Demo_1.105.697.2_x64__8wekyb3d8bbwe
Faulting package-relative application ID: forzamotorsport7

And under the Details tab:

  • System

  • Provider

[ Name] Application Error

  • EventID 1000

[ Qualifiers] 0

Level 2

Task 100

Keywords 0x80000000000000

  • TimeCreated

[ SystemTime] 2017-09-24T03:49:15.351363400Z

EventRecordID 473422

Channel Application

Computer Quad7


  • EventData

C:\Program Files\WindowsApps\Microsoft.ForzaMotorsport7Demo_1.105.697.2_x64__8wekyb3d8bbwe\ForzaMotorsport7.exe
C:\Program Files\WindowsApps\Microsoft.ForzaMotorsport7Demo_1.105.697.2_x64__8wekyb3d8bbwe\ForzaMotorsport7.exe

The 0xc000001d code is the same I was getting with Apex.

And I have just run SFC /scannow and DISM using the RestoreHealth option, which can be fixes for these errors, and neither finds any problems with my system files or makes the game function.

Ahh yeah, that exception code means something is wrong with your windows, either registry entries, corrupt or missing files etc etc.

You can try two things, but first make sure you have a backup of your harddrive before doing these kind of things.

1 : Download “Windows Repair” - - Windows Repair Free/Pro (and let it try to do all the repairs)
2 : Reinstall Windows 10 clean (which is always a better options in these cases).

I’m getting the same, crash after turn 10 logo, did u fix it?

The Tweak tool did not fix the issue unfortunately, and for the most part found no issues…I am puzzled as this error doesn’t happen on any other game or program aside from the two Forza PC offerings. I could see that the memory loads up and stops at about 1.9GB and the task manager then shows the game as not responding. I tried switching processor affinity around quickly while it was open, and with some configurations the memory loaded up to 2.5GB, but the game still closed. I tried switching the priority, checking the “Wait Chain” which once showed that F7 was waiting for explorer.exe, and another time it was waiting for svchost.exe, however most of the time it showed nothing.

I don’t really want to re install Win10 since my PC is due for an upgrade and I plan on doing a fresh install then…

I was so annoyed I ended up downloading the demo on my Xbox and hauling upstairs to hook up to my PC monitor. Which works, but I don’t really want to do that all the time since it’s normally a media hub on the main tv (which is in an area not suited to set up my racing wheel / pedal / chair setup). It did look really nice and ran smooth, but took me a while to get the force feedback to feel right on my TX wheel. But I’d still really like to get this running on my PC to see how it runs / looks in comparison.

I’ll keep trying.