Cant select F1 car online

So I have just dropped 1.7M credits on the #5 Lotus 77 F1 car but when I go to race online it it does not appear in my garage and cannot be selected.

Does anyone know how to fix this?

What class are you trying to race in? I’m not at my console right now so cannot test this but if it’s R Class then I know in FM5 they didn’t allow you to race the F1 cars in the lobby as they were so much better than nearly any other car in the class.

Hopefully someone with a bit more knowledge will be along shortly to confirm this

The Lotus E23 is X999 if I remember rightly, so you’ll need to be in a lobby that allows that restriction.

Wouldn’t be surprised if the R-class F1 cars don’t appear though. Those are ridiculously fast and insanely grippy.

The F1 car is X class so unless you are in a X class lobby you won’t be able to use it.

Ah my bad I thought he meant one of the older ones. To the Op you have to use that car in an X class lobby - if it still doesn’t allow it then I’m not sure what else to suggest.

Actually it’s my bad thought he was talking about the modern F1 car but the 77 is right at the top of R class.

Ok I just went on & tested this and it looks like you can’t select any of the 1970’s GP cars online.

Yeah the classic Lotus starts out in R class but is unable to be selected, I have also tried upgrading it to X class but still it is nowhere to be seen in the garage.