Can't get Logitech G27 to work at all in Demo

I honestly don’t know what I’m doing wrong, I have my G27 all hooked up properly, I’ve set my default settings to the G27 controls, but I can’t navigate the menus or drive at all. The only time I can get the game to respond in any way to the wheel is when trying to remap the buttons, and that hasn’t done anything for me either. I’m worried because I just pre-ordered ultimate edition and now it won’t even work? Super stressed, can anyone help?

That’s a bit strange. So I use the drivers that installs with the Logitech Gaming Software…the old one you can download from Logitech’s website. Mine works within the menus just fine but is super responsive when trying to drive. I’ve done everything possible to rectify this but with no luck. My plan is to do what I did with FH3, drive with a pad.

The simcade physics probably won’t work well with a wheel any way.

I suffered the issue too. I removed all the drivers, I removed the device itself.
I run the WheelDriverCleaner.exe executable (you can find it on the net, I dont remmeber the url)
after this everything worked fine, the G27 was properly recognized by the game.

This sounds like it’s worth a try. I will do some testing this evening.

I got it fixed, for me it was that I had the wheel’s USB plugged into a USB hub, once I plugged it directly into the computer everything worked fine.