Windows Build 1903 and excruciatingly long load times

samers boys…

This is not fixed with Lego update. Come on devs. Can’t you see the increased load times?

1 Like

Same problem. Only in Forza Horizon and only after I updated to Windows 10 1903. Using a i7-8700k with an fast M.2 SSD so there is definitely something wrong with the game or UWP games in general.

Also the installing and update experience of Windows Store games is awful. If you own the Ultimate Edition you have to manually search for the included items ans expansion and install them separately.

And also the game just created a second folder which means it utilizes two identical folders under c:/programs/windowsapps with 70GB each…please fix or move the game over to Steam lol.

Update 2:
I can finally play again but the loading times are still 3-6x longer than before the lego dlc release week.
I am now on 1809 again and the loading times are definitely not because of 1903 but more likely an issue with the new game version in general since the lego dlc release week. Even without dlc the game starts very slowly.

Also I had a strange bug when I quit the game after playing the lego dlc until to the point where I got enough points to upgrade the lego house for the first time. This resulted probably in my game crashing everytime it would have tried to spawn in that bugged house. Setting a house on the mainland as home and upgrade the lego dlc house first before trying to spawn in there fixxed the crashes for me. ( Thanks to: Fix for freezing while loading FH4 (after LEGO DLC) - Community Support - Forza Motorsport Forums )

Update:

I just went back to 1809 and it seems that the crashes still appear after the second time launching the game. I read on the forums here that it might be an issue with redownloading the game while you already played the lego expansion to the point where it sets it as the new home. I am now redownloading (because after uninstalling the lego expansion it just started redownloading the whole 72GB, why not its the usual UWP/Microsoft Store experience) and trying to download everything but the two expansions and set a new home in the mainland. I will let you know if it works whenever this stupid download finishes for the 5th time this weekend.

You have a completely different problem and warrants a separate topic. Guys this is not “Uff my game is not launching” issue. This topic is specifically created for dealing with long loading times before loading Xbox gamer profile after intro screens.
I myself have zero crashes. This is SPECIFICALLY related to Build 1903.

I am on 1809 and it is the same problems. I just posted on the thread “FH4 not launching” what I did to try to get it to work. I think it has to do with internet connecting through the teredo adapter. I did some research and I can get it to run, but most of the time it takes a couple tries. Go into your xbox networking page on the xbox app or through settings\gaming page on windows and see if it is running ok. I was getting “does not qualify” on NAT type and i think this may be part of the problem. Read my post in the other thread.

This really isn’t a different problem. For some people the long loading times have turned into crashing also. I have never been on build 1903 but started getting the long load times, and then crashing. This is not specific to build 1903.

the only fix ive found for the long loading times is to uninstall all the dlc i guess there is a checklist for every single dlc installed which results in a minute or two for it to confirm with the server? i dont know just my guess since ive tried it with dlc without dlc then instantly back with dlc without ever loading into the world between them.

Still not fixed.

same issue

it only started after updating to 1903

Idk what constitutes a 'long loading time, but for me, it cycles almost twice through the Senna driving through different seasons before switching to still shots with ~records listed at bottom of screen. About 2.5 minutes from time I launch until garage. Build 1903

I am having same problem. It takes around 10 minutes for me to show the continue button. If I disconnects internet, the continue button shows up instantly (offline)…

Loading times became much longer on my system after 1903 update too. Like CRracer 912 pointed out, Sena intro cycles almost two times before the menu appears.

One month and one update later still no fix.
not even a word from the devs.
this is a shame.

No improvement even after update. Do the devs absolutely don’t see the delay in loading?

Just to add to this, on both a gaming desktop and gaming laptop, both running NVME SSDs, the laptop was a new install of Windows 10 1903 and the game. Both have long loading times during the opening video (it cycles about twice) It’s been an issue with the game since the LEGO update.

I have the same problem

Try the solution I described here :

That link has been removed.

Yes, sorry about that, a bot removed it, but now a mod enabled it again.