Stability - Game may hang on applying upgrades and does not save career mode progress (1608827)

Getting this also. XSX in performance rt mode. Currently doing the featured cup but was happening in other series also. Choosing upgrades between races, hangs on ‘applying upgrades’. Have to exit to home screen and force quit game to resolve. And then it wipes your last race and you have to do it all over again.

Just happened again after only 3 races this time. Considering I had already redone the first one and now Im going to have to redo the last one again thats half an hour spent to progress a single race.

Can this please be looked into urgently. Is souring an otherwise great experience.


Same issue here on Xbox series x


Same issue on pc, in the practical performance event. No matter how many times I try, the game just freezes after having done the final event of that series and I have to force restart the game on pc, which immediately resets my progress back to the start of the series. Car upgrades, levels and credits save but event progress doesn’t save at all, neither does player level.

Very frustrating issue, especially since the game recognises that ive completed the series and awards me a trophy for doing so, yet then doesn’t let me progress and marks the event as not completed.

Please fix this quickly as its making the campaign completely inaccessible which is very frustrating, especially for someone who isn’t a multiplayer racer.


Continuing the discussion from Stuck on applying upgrades:

Initial walkthrough, first race done, upgrade menu comes up, goes thru options then freezes when given the choice to apply, choose upgrades, auto upgrade, or go back. Had to fully exit the game and return.


XBOX - Frustratingly, have had the game hang multiple times and lost save progress multiple times. Once when I was quick upgrading my Hyundai Forza edition the game hung up and I had to dashboard and restart the game. Lost the last two races I had completed in the Modern Tour - Practical Performance series.
Finished the races again, tried to load the next series, built for sport and received the loading event data prompt which then failed with a message saying “remote data not yet available.” So I restarted the game. Lost the completed final two races in the Practical Performance series once again. Like an idiot, I did the two races again, then went to look around the menus and tried to load a design for a car from My Designs. Game got hung up on a loading screen, had to restart game again and guess what happened, lost the two final races of Practical Performance yet again.

After playing every single Forza game religiously, I cannot believe how bugged and unplayable this seems to be. We are the beta testers for a game far far from complete. Bugs in games happen, don’t get me wrong, but the simple basic ability to save progress and not have the most simplest of actions cause crashes and loading hangs should have been covered well before release.

Pictures attached are the remote data error message, as well as the two series I’m having trouble with. The pic with the first completed series was taken hours before the picture which shows two more races to finish.


Update: Reinstalling windows does not improve the error at all in my case, with it occuring both with windows 10 and with windows 11 installed, furthermore clean installing the game on a fresh copy of windows did not remedy the issue.


Im having the same issue on Xbox Series X. Seems to happen when applying upgrades & tunes in-between races when it gives you the option to do so.

Hopefully gets sorted asap as I cant progress any further.


Just 2 races completed this time before it happened again. This time it was after I had completed a series and was trying to purchase a car for a new series.

Same deal again - have to force quit only to find all that progress is lost and Im back on the last race of the old series again.

I can put up with the crashing but for the love of god can we please get it so its saving immediately after a race is completed so we arent having to redo the same thing over and over again upon restarting.


same thing happening to me

game stuck when
-applying upgrades between races

  • sometimes when saving game (buying car / changing paint)

then I have to force quit the game, and lost almost all progress done (no matter how much I progress, I return to 2 finished races in first championship)


same issue happening to me on series X, I keep playing the same races again and again.

guess its server side issue thats causing the stock on upgrade/save.

we get the deluxe edition and cannot play :slight_smile:


Yep, without a fix for it, it is hard to play with the fear of having to repeat races over and over again.


Having this same issue too


Yep finished the practical performance event and then reverted me back to 2nd last race (Miami) in that cup. They should be making this priority id hope seeing as we are the ones that bought the deluxe version of their game… only to have a broken demo.


Same thing is happening to me on my Xbox Series X, also when applying Upgrades and Tunes.

It happened to me twice within an hour, and you loose all the current sessions progress.

It wouldn’t be so bad if the game was saving between races, but at the moment it’s too frustrating to continue playing until it’s been patched.


I’m pushing this issue, it happens very often while I’m streaming.


I’m here at the exact same point. Hangs multiple times, lost progress. Happens when trying to upgrade mostly.

Had instant crashes at the end of a multiplayer lobby.

I’m getting this on PC.


Same here on Series S , game hangs whilst applying upgrade . Even finished the modern tour , went to play some multiplayer , game crashed at one point , went back to builders cup and I’m back at lime rock, really annoying bug


I also have had this happen to me. Twice now. Once when I was looking for a new design and another when I was upgrading. Both times the Hyundai Veloster N Forza Edition and lost progress on the series, practical performance. This car is now level 11 and I’m level 7 so progress on those hasn’t been lost.

I will also refuse to play this game for now until it gets resolved. Clearly can’t trust it at the moment.


The upside is that I’m not alone on the above issues. Still though, extremely frustrating paying for a premium product only to feel like a guinea pig for Turn10 to iron out bugs.


I’m on pc and having this exact same issue, opened a ticket with turn 10 support but idk what the resolution would be.