Free play not working, please help

Started forzathon yesterday. Did maple valley in chevelle, checked forzathon, didn’t register. Come to forum and saw others with same issue, no big deal, it’ll get sorted out.

Did the rivals part of forzathon in the VIP section, used the Fe rally car. Beat 4-5 rivals, quit and checked forzathon. That one registered. Went back to free play after reading the thread in main discussion to try some other things. When selecting a car the game froze. Gave it some time, then used the Xbox button and quit the game. Launched game and back to free play. Set up the race, raced it, still no register. Ok try another event. Setup up race and hit go to race, it does its thing, changes screen where you get the race info just before you normally get the start race menu. The track info(the three lines of text over a background goes away and the background freezes, never bringing up the start race menu. I can hit b and here the click. I can hit a and it takes me to the next screen where I should see the start race menu, and I do, with car in the pit and my driver. But instead of it saying start race, it just says loading race.

I came select all other options and reload but I never get start race, no matter how long I let it sit. I did a hard reset, same thing. Cleared the saved data and save file, launch and reload save from cloud but same thing. Plug hard drive into Xbox one s(, previously on Xbox one x), launch game, same thing.

Tried a race in my elite cup, worked as intended. Tried free play still no luck. Fired up the Xbox one x and did a fresh install to internal hard drive. Just tried out fresh install and freshly still won’t work??

Please help, I don’t know what to try next

Before you select go to race, change race type off of custom and over to circuit. Worked for me. Credit to DeusZero he found that the glitch has to do with changing buckets and changing from custom fixed his and mine.


Thank you thank you thank you!!! And thank you DeusZero!!!

I did check and it was on circuit. But after my initial maple valley run, I do remember turning off buckets and that’s it, it was sometime after that that it occurred, but I didn’t put those together since I’d had that lock up in garage selecting a car. So since is was already set to circuit, I cycled through timed etc, back to circuit, selected me hatch and it worked!!! Got my next check off in forzathon too.