Fortune Island issues

Hello, I am having a issue with fortune island. It is purchased and installed, the game is updated but when I drive up to the fortune island teleporter a screen pops up telling me to install the expansion pack. Which I already have installed. I’ve tried to re-install the game and the expansion pack as well as re-booting the console itself but it just tells me to install fortune island everytime I want to go there. I don’t know what else to try. Anyone?


Same here on PC…

Same here on xbox

Same here. Reinstalled. Nothing…

It was like that for me for a while and I just went to play and it worked. I’m guessing just wait till it works :man_shrugging:

On xbox i had this problem, i tried doing a hard reset, and it now it works

Hard reset worked for me to :grin:. Thx for the tip​:wink:

same problem i removed game and dlc install them again same problem ech time it says install dlc and already installed

Same issue in my Xbox One X. Unistall and reinstalled nothing. Installation for the expansion took like 15 seconds. I know the X is faster but for 7.3 GB it should take quite a bit longer. Need some input from T10, Playground and/or Microsoft.