Fanatec help

So after I get my rig set up last night I took a few laps to see how it feels… HORRIFIC is putting it mildly. The ff doesn’t want to stay with where the car is heading so that means instead of counter steering for you it wants to just stay straight with the car. I actually have to force the wheel into the direction my car is sliding. I thought the worst that my wheel was defective. Dirt rally feels amazing… Ok some positive news there then for grins I put in Forza 5 and that felt decent as in Forza 4 like feel.(like it should)
So if anyone could help me that would be awesome and FYI I got the update last night for the new pack I’m guessing? So is anyone else having this problem??

What vehicle and what type of tune set up are you using? What are the upgrades done to the vehicle? Are you just wanting to drift or get points? If it’s points, check out my thread. The set up on there can be used for a wide amount of vehicles in this game.

From stock to my tunes which should be more than fine. Unless there is a secret to achieve correct force feedback. Also I’m no amateur to drifting in Forza. The tuning has been the same since Forza 2 but with different physics each game

I remember someone asking about wheel FFB, and I mentioned in that thread that the FFB is not designed well due to the way that T10 designed it (plus or minus a few factors in-game). Due to Forza being a ‘simcade’ it’s FFB will not be that great. I won’t repeat myself so I’ll just link you to what I mentioned.

It’s not for a Fanatec but the situation is the same.

The FFB isnt great in FM6, and it seriously needs working on. But all the people saying it is impossible to drift at 900° are pulling your chain.

Those are the settings I use for the G920 wheel.

@Fizzle Nog, Good to see you around. You need to look for a person on here called ‘Blue028’, as they use the fanatec wheel. They should be able to help you find some semblance of order with it, and give you a base to start with in regards to the on wheel settings. In game, make sure you are vibration set to 0% and ‘Rumble’ turned off. I find they get in the way and make the problems worse.