Can't Download the Beta

Hi,

I’ve been having an issue where I can’t download the beta even though I have Windows 10 installed and a PC that surpasses the minimum requirements. It just has the Free button greyed out and is telling me to visit the Microsoft website to upgrade to windows 10. It says i need version 1511 of windows 10 when I have version 10240 installed. All updates have been installed and I’ve restarted my computer several times.

Forza

Any help?
darkavenger786

Same at me
AMD FX-6100
8GB Ram
Geforce GTX 470 AMP by ZOTAC
Win 10 x64 Build 10586.218 (Newest non Insider)

Download this http://go.microsoft.com/fwlink/?LinkId=691209
and select ‘Upgrade this PC now’ to force your W10 installation to version 1511

I’d rather not go through an entire installation process again just to play a game

Then not play this game? Or do a bit of looking around since build 1511 was available for Insiders last November and was released for normal users about a month ago. 1511 should be listed as a (mandatory) WindowsUpdate.

If it is not listed as an update, please contact your local Microsoft customer representative (unless you have an OEM install).

Didn’t work :frowning: … Thanks anyway

I’ll have a look. Thanks

Have you tried this? worked for me. I had the same problem. It will clear the Windows Store cache+reset it.

Press WIN+R keys together to launch RUN dialog box and then type wsreset and press Enter.