[ANSWERED] Free play broken

I can’t load a free play race on Yas Marina North circuit. I select the track in race setup and select go to the race and i just get a blank view of Yas Marina on my screen with no other information like mods, assists, start race, etc.

Tried this on other tracks as well and i get the same result actually; so i literally can’t play a free play race right now.

Restarting Forza 7 DOES NOT fix this problem.

What system are you using?

If on Xbox, have you tried a hard reset of the console?

1 Like

Sorry; should have mentioned that i’m using Xbox and yes, have tried a hard reset and this still occurs on ANY track for me in Free Play mode.

Multiplayer seems to work fine, Rivals works fine, and I haven’t tried single player career races because i’ve already finished everything.

This happens from time to time go in to free play and go to race settings Then Press Y 5 or 6 times go to next menu and press y again do this for all the race menues exit free play exit game re boot and then start game Free play should now be fully reset and work again.

I have had free play lock up from time to time and doing this has all way got it working again.

1 Like

Odd, could be a save corruption issue but I cannot say for certain. I would email forzafb@microsoft.com so they can look into your profile and see if there are any issues there.

Before loading the track use the reset button in the pre race menu (I think it’s the x button). After resetting you can change all settings back and load the track. This happened 3 times for me so far since I got the game.

1 Like

Sorry for the late reply to your answers but pressing the reset button on everything in race settings, etc…backing out and restarting has fixed the problem. Not really sure why this happened in the first place, but glad i can do some races again.

Thank to everybody who suggested fixes!

I they need to fix it i can’t put 20 laps and cr