Achievements not unlocking?

Whihc achievements are not unlocking, which region are you playing in, and which platform are you guys getting this issue?

PG have already released a patch that fixed several Acheivements that was not unlocking for us (

Most of the time it is a server delay, while other achievements would pop after you do a cold reboot of your console/PC/Modem/Router.

Once all of those have been ruled out then it would be a game issue, but since only a few players are having this issue, it kind of points to a system error.

1 Like

It’s not just a few people, there are threads relating to this all over the internet. I have about 5 of the common achievements that won’t pop, tried most solutions except deleting my save and starting again.

1 Like

I have three that won’t unlock

The perks one
Complete all exhibition races
Fully Upgrade all festival sites.

It’s been weeks since these were achieved and nothing has popped. Tried a few of the solutions which have not worked for me. It seems that these are the most common ones with a problem so not sure why it has never been fixed. Very frustrating :frowning:

FH2 Storm Island DLC Gauntlet Runner
FH3 Blizzard Mountains DLC Frozen in time

Seems I am lucky with only two achievement that would not unlock.